has my back light inverter gone? mitac ipower

  LivEviL 09:37 30 Apr 08
Locked

Hi i have a mitac 8640 i power ( the same as the packard bell ipower 5000) i think the back light inverter has gone, as when i turn the laptop on i can only see a faint picture of the linux loading screen and all lights and beeps happen! can anyone comfirm that it is the inverter? and if any one has a spare one can i have it pretty please! thanks

  Ditch999 09:41 30 Apr 08

If you have an external monitor connection eg vga or svideo, hook it up and if you get a picture your screen is the problem, and it does sound like the inverter or backlight has gone.

  Gongoozler 09:45 30 Apr 08

If the faint image has no light in it at all, then it could be the inverter or it could be the tube. Both are replaceable, but not easy to do. This gives an idea of what is involved. click here. This will give you an idea of the cost click here.

  LivEviL 12:45 30 Apr 08

i think it is the inverter as iv just taken the screen cover off and the inverter smells like burnt circuit board although no signs of damage, it works fine through the external screen. what a bugger!

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…