Hardware wizard and XP

  JRTH 13:54 31 Dec 03
Locked

I have just installed XP Pro on a new PC. As expected, the Hardware Wizard popped up wanting to install things for me. If I let it search it autmotically, no drivers (for printer, scanner, external usb drive, etc) were ever found. If I then let it go to the internet, it also can't find them. To get it to work, I have to tell it to search in a specific directory and type in "C:windows/inf". Everything then loads fine so the drivers are there.

Obviously this work around is ok for me but I'm curious now. I would expect the wizard to look in c:windows/inf for the automatic seach. Any idea why the hardware wizard does look there?

  Big Elf 14:04 31 Dec 03

Did you have the CD supplied for each item in the drive at the time? I think that the drivers in c:\windows\inf are possibly the generic ones so may not be the optimum ones to use.

  Mankster 14:07 31 Dec 03

hi,usb devices software should be installed before you connect the device,then you turn your pc off, connect device turn it on if its printer,start your pc up and then the wizard will automatically detect and install.

  JRTH 14:25 31 Dec 03

the ones from XP were the best ones in most cases or I had already run the driver CD so they were in windows/inf. In general, I didn't have software. I had the problem on every device I connected -modem, printer (non USB), scanner, ethernet card, etc. For example, if I plugged a USB 64MB external drive in, it couldn't find the drivers unless I pointed it to C:windows/inf.

  Big Elf 14:59 31 Dec 03

I found this which may explain click here

  wotbus@ 15:44 31 Dec 03

spotted your tip! I have been trying to get my new camera to talk to my PC (XP) since Christmas Day!! I have checked the Fuji FAQ and followed all their instructions; the s/w has been in/out several times and still it wont work.Camera and lead check out "S" on my old PC (Me), straight in and works perfectly.I am beginning to wonder why I upgraded? The drivers are installed OK,Device manager confirms all OK,but when I plug the camera in and switch it on, nothing happens. I can see the drive in My PC and if I navigate Removeable Disc > DCIM > 100Fuji, I can see the images on my camera.I had big problems with my Scanner a while back, same sort of thing, but that was cured by removing all related s/w-downloading s/w direct from HP then running their .exe file and following the instructions. I have tried the same thing with my camera but no such luck. I havnt tried your tip though so wish me luck.
Happy New Year if I dont get back until tomorrow.

  jimv7 16:51 31 Dec 03

Have you installed SP1 yet, this overcomes some problems with usb.

  JRTH 18:05 01 Jan 04

Thanks Big Elf for the pointer - that is what I was looking for!
p.s. yes I have installed SP1

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…