Hard Drives - wrong sizes displayed

  Binstock 20:56 30 Nov 05
Locked

I just know I've seen this question asked; & answered before:

I've just reinstalled Windows 2000 SP4 on my FTP-server. I installed it (alone) on a FAT32-formatted disc.

However, - now under 'Properties' the sizes of the 2 OTHER Hard-Drives on the Computer, - are wrongly displayed.

Both are 80GB, - but one of them (an empty-one) is displayed as being only 31.4GB.

There IS somethimg about the Maximum-size that an O/S on a FAT32 drive will display..... but before the Re-install, - BOTH drives were shown as 80GB & 80GB.

What do I have to do, - in order to make the O/S display the CORRECT Drive sizes? I'm fairly sure I have read this problem in the PC Advisor Magazine, - & I'm sure there is an answer.....

If so; - can someone tell me what it is, please?

Regards

Bitsko

  PC Bilbo 21:59 30 Nov 05

You would do better to format in NTFS.Try reading this link and hopefully it will answer your question fully. click here

  woodchip 22:01 30 Nov 05

it's a fat32 problem, change to ntfs

  Fruit Bat /\0/\ 22:38 30 Nov 05

(start > run > regedit <enter>) and go to the following folder HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters there add a new key named "EnableBigLba" , type: "REG_DWORD" and "value 1" (excluding the quotes (")) now restart and your windows will see the true size

  DieSse 22:45 30 Nov 05

Win 2000 will not create FAT32 partitions larger than 32 Gb. So if you redid the drives from scratch that will be your problem.

If they were already formatted to larger than 32b - then Fruit Bat /\0/\ s advice is worth a try.

Redoing them in NTFS is the better solution, as it's a better filing system all round - and more robust for server operations.

  Binstock 23:03 30 Nov 05

The 80GB Drive that shows as only 31.4GB IS Formatted in NTFS....

I confess that the small drive with the O/S on it is Formatted in FAT32.... so it is THIS that prevents the other drives from being displayed properly? - If I Partitioned the 80GB drive into... 27; 25; & 25GB, say (since no drive is as big as is Claimed AFTER Formatting) - I would be OK? Is that right?

Binstock

  Binstock 23:08 30 Nov 05

@Fruit Bat:

Would you be kind-enough to Post a more-detailed answer?

I'm no expert, as you can tell & I'm not used to Registry Edits...... they worry me.

Thanks.

Bintsock

  PaulB2005 13:44 01 Dec 05

bump

  Binstock 20:58 01 Dec 05

I tried the suggestion from Fruit Bat....

Easier than I thought to-do...... but after Reboot, - the Hard drive sizes were..... 31.4GB

.....& I (nervously) followed Every Step, - exactly.

Thanks for trying, Fruit Bat

Binstock

  Fruit Bat /\0/\ 21:22 01 Dec 05

Check in BIOS that booth drives are reported as the correct size.

especially if on different ide channels

HAve you got a jumper to limit the drive's capacity to 32GB, as shown here:

click here

I should clarify; just remove the jumper from those pins and the drive's full capacity should show up fine.

try in device manager to uninstal and reinstall the IDE channel the drive is on.

May be click here will help.

  woodchip 11:42 02 Dec 05

Don't know if anybody said above but check drives do not have a 32gb jumper

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…