Hard drive is working overtime but on what?

  Philip Stokoe 19:18 28 Mar 08
Locked

Computer: Dell Dimension 9200; Vista. there are times that the hard drive (which is noisy anyway) suddenly seems to burst into manic activity and everything else slows down to a snail's pace; it will even 'spring out' of sleep to do this. How do I find out what's going on? I can't understand Task Manager and I've not found any software that actually identifies what the computer is doing in plain english so that I can decide what to do about it. Is there something like that out there?

  STREETWORK 19:26 28 Mar 08

One way of solving this is to add more memory, appears to be due to disk space being under 100mb, what memory do you have installed?...

  wee eddie 20:59 28 Mar 08

If you have 1GB or less Memory, your PC is using the Hard Drive as Virtual Memory.

  Philip Stokoe 09:04 31 Mar 08

Thank you for these comments: I have 1GB of memory and there remains 150GB free on my hard drive. I take the point that it seems that I ought to increase the memory but I still don't know how to discover exactly what my computer is doing - is there any software out there that does that (in terms that I can understand?).

  wee eddie 10:28 31 Mar 08

and is literally caused by Vista running out of memory, it's very hungry that way, and it is unlikely to be any particular program but just your PC's requirement to work.

A visit to Crucial's website will give you an idea on how much it will cost click here

A visit to YouTube and put "Install new RAM" into the Search box will show you how to do the job.

If the PC is new, check the Warranty and if it says anything about not opening the box, ring them and ask for permission to install extra RAM.

  Philip Stokoe 10:50 31 Mar 08

Thank you, I've been to Crucial and ordered an extra 2GB of memory on the grounds that they say that my 32 bit system won't recognise anything over 3 or 3.5GB. Glad to know that it's normal, even if somewhat alarming.

  skidzy 15:55 31 Mar 08

to reduce the hdd activity disable Vista's Superfetch from services.

In the start search (windows orb) type

Services
And enter,now scroll through to Superfetch and stop this service.

This may take a reboot to have effect.

Basically Superfetch is working away learning your computer habits.
A little bit about Superfetch click here

click here

  Rigga 16:26 31 Mar 08

Help stop disk thrashing in Vista. > click here <

HTH. R.

  DieSse 16:54 31 Mar 08

If it springs out of sleep - it isn't really thrashing. It's more probably the indexing service, as noted in the link in the previous post.

  Philip Stokoe 16:06 10 Apr 08

Thank you for all your help. I've loaded more memory and that has certainly stopped the thrashing; I've also disabled Superfetch as you recommended and the computer is making less noise and hasn't woken itself from sleep.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…