GTX 660 Not working.

  mrwoowoo 25 Dec 12
Locked

Bought a GTX 660 graphics card, and i am having problems. On boot up the boot screen is immediately corrupted with streaks/lines of blotchy colour. If it gets as far as the Windows login screen (which you can only just make out) it usually freezes and i have to reboot. On the odd occasion that i have got further, i have tried the most recent driver, older drivers, and Beta. All with the same results. It replaces a GTX 260 which requires more Wattage and more amps, so the PSU isn't the issue. The 660 is pci-e x16 (3.0) But is backward compatable with my 2.0 m/board. Windows 7 64 bit 12 GB DDR 3 ram Intel i5 CPU. When i put my GTX 260 back in all is normal again. any suggestions/ Or do i just take it back to my local PC shop for a replacement?

  rdave13 25 Dec 12

It is definitely faulty, whether new or second hand. My last ATI I had died a similar way. First it showed faint, dotted, rectangular shapes then went on to colour bleed, fuzzy display then nowt. Ask them to check it out.

  mrwoowoo 25 Dec 12

Thanks Dave. I thought as much. But it doesn't hurt to dream.

Advertisement

This thread is now locked and can not be replied to.

Windows 10 Home vs Windows 10 Pro comparison: Here are the extra features you get in the Pro version

Why Formula-e needs to go faster

How Instagram spots trends

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message