Graphics Card

  fazer 17:27 26 Feb 05

Please help ...

Have just gone out and bought an ABIT Radeon 9600 graphic card from PC world to replace my Nividea MX440 which came with the computer.

On paper the new card is twice as powerful (memory and clock speed)hence why I bought it. Unfortunately, the results are worse than my old card. The only game I regularly play is Flight simulator and thought that a more powerful card would improve the quality and frame rate - but as I've already stated, this new card is worse than the old one.

I think I've done everything right in that I uninstalled the previous drivers, gone through all the (cards) settings etc. downloaded the latest drivers all to no avail.

The main problem with its performance is the aliaising bit - even my desktop icons are poor quality with jagged edges.

Am I missing something here or have I been naive and bought the wrong card?

(running Windows XP -2ghz processor and 1.2gb of memory.

  Taw® 18:15 26 Feb 05

If you have downloaded the most up to date version of the drivers i would try uninstalling them and using the previous drivers, or else the drivers that came with the card. Sometimes the newest drivers can cause probs.

  LastChip 18:19 26 Feb 05

The card you have bought should be very good quality.

What screen resolution are you running at and have you made sure that resolution is supported by your monitor? It sounds from what you describe, you have a miss-match somewhere in your settings.

  FelixTCat 18:34 26 Feb 05

Try the Omega drivers: click here

They often perform better than the normal ones.

  fazer 19:29 26 Feb 05

Last Chip

I'm running a resolution of 1024x768 @85mhz refresh rate (which I have always done).

  Starfox 20:33 26 Feb 05

Compared to your old MX440 card your new one should give you fantastic performance. Suggest you do as Taw says and re-install the drivers that came with the new card.

One problem that I have come across when changing cards from Nvidea to Radeon is that you can get a conflict somewhere.Make sure the old drivers have been totally removed.

  mtall 20:37 26 Feb 05

Use a third party uninstall program to uninstall the old drive before installing the new ones


  fazer 21:55 26 Feb 05

Thanks guys - I'll try your suggestions.

Er - one question concerning "mtall's" response; I uninstalled the drivers of my old card - is this is the same as uninstalling the drive as you suggest? All I did was pull the card out the back of the computer!

  Starfox 22:05 26 Feb 05

Did you go into Control Panel + Add Remove Programmes to remove the Nvidia drivers. If not then do so.

  LastChip 22:21 26 Feb 05

Open up Device Manager and expand the Display Adapters icon. Highlight your present graphics card entry (click on it) and select the Remove button. If there's more than one entry, Remove them all. Don't worry, all will be well!

Now shut down the machine.

Re-start and XP will show you it has found new hardware (your graphics card) and ask you to install its drivers. Click cancel. Next, XP will boot into a basic graphics configuration and will look horrible, but this is the time you put your CD in the drive and let ATI install the correct drivers for your card - just follow the wizard. When it's finished, it will ask you to re-boot the machine; do so, and hopefully, all your woes will be over.

  fazer 10:27 27 Feb 05


Under Device Manager, my new card is listed twice with the second entry labelled as "secondary" - all specifications are identical between these two entries. Is this the problem then? (before I delete them both and start over?).

This thread is now locked and can not be replied to.

How to watch Surface PC live stream | Surface PC release date, price, spec rumours: All-in-one…

1995-2015: How technology has changed the world in 20 years

Best Photoshop video tutorials: 8 video tutorial websites for Photoshop

Apple's event invitations decoded: A look back at 16 of Apple's most cryptic invites | Clues in…