Google won't use my default (non-geographical) Google homepage

  polymath 21:40 03 Feb 15
Locked
Answered

Having had this default homepage for years, Google is now refusing to use it, and has reverted to the Google site based on my location in Ireland, Google.ie. I would have gone to the non-geo site to see if I could confirm it as my homepage from there, but can't (I get redirected back to Google.ie).

The reason for the non-geo Google page is that I was fed up with Google automatically prioritising search results from my country (If I want to narrow down a search to a location, I'm quite capable of using Advanced Search!).

I use Firefox normally, but it's the same in Internet Explorer (so it's not down to Firefox add-ons, which in any case I've been slimming down rather than adding to). Firefox, Internet Explorer & Internet Options all still have the default homepage I want (and nothing else in the drop-down list).

I don't know if it's relevant, but I can go to Google UK & Germany ok, but not Google.com (I'm sure I used to be able to go there).

I don't know anyone else within reach who has a computer, so if some kind person could try the URL for me, I'd have a clue whether it's Google's fault or mine. The trouble with this is that you'll be rightly wary of trying it, and I can't remember where I found it (some like-minded tech blog, I think). But it's just possible someone out there might recognise it (or even be using it). It's click here

  polymath 21:48 03 Feb 15

Via the above posting, the link still goes to Google Ireland for me. But then I suppose it would (time for a good night's sleep. methinks!)

  polymath 21:53 03 Feb 15
Answer

Definitely time to knock off (of course it just says 'link' here, so nothing to recognise!). I'll see if I can do it as a harmless image file or something (in the morning).

  Fruit Bat /\0/\ 21:56 03 Feb 15
  Secret-Squirrel 09:04 04 Feb 15

Polymath, I found the following on Google Support - does it help at all?

...................................................................................

Visit Google.com instead of your local domain

If you want to use google.com instead of your local Google site, you can. To use google.com for searches, you have two options:

1) If you've been redirected by google.com to another google site (like google.fr), click the google.com link in the bottom right corner of any other Google page

2) Bookmark 1.">**[click here Anytime you visit this page, you’ll be taken to Google.com.

  Secret-Squirrel 09:08 04 Feb 15

........oops, the forum software has messed up that link - here's the link to the support document.

  Newuser4165 09:29 04 Feb 15

I find if you type "www.google.com/ncr" (no quotes) you'll end up at google.com. Similarly google.fr/ncr takes you to google france.

  polymath 14:02 04 Feb 15

Wow, Fruit Bat - another location-free page? Looks like it - Thank you! I've made it the default Google homepage in the desktop (laptop next). I've used only the laptop recently, so fired up the desktop today to see if the problem was there too (thinking a little straighter today!). It is indeed (and its settings etc have been unchanged by me for about a year, unlike the laptop). So I suppose it's Google doing away with the old non-geo page. You were very quick off the mark - do you have the same trouble with 'personalisation' as I do? While I'm at it, do you happen to know of any way to use wildcards in search terms? (I found it very useful in the days when Google allowed it).

Thank you Secret-Squirrel and Newuser 4165; it'll be useful to have that info for future reference. If I remember right, I used to use Google.com before I came across the non-geo Google (seem to remember it improved search results; maybe it was the US one & had more results to choose from?).

Just out of curiosity; the URL of every Google site I've been to lately has additional stuff after the country code; is this normal? (Thought they used be just google.(country code), but may be remembering wrong).

  polymath 14:18 04 Feb 15

...I'll wake up in a minute! (A cold - that's my excuse). Forgot we can put URLs here in quotes; this is the one that stopped working for me "click here

  polymath 14:20 04 Feb 15

Trying again "click here

  polymath 21:48 14 Feb 15

Sorry this has taken so long to resolve - I've only just got Fruitbat's link properly established as my homepage. But I'm afraid I don't know how, as it's still a mystery to me!

I set it as the homepage soon after my last posting (by dragging the URL to the 'Home' icon, and also doing it via Options). But noticed today that it had reverted to the Irish Google (I don't know how long ago). I reset it again several times, but it always reverted on restarting Firefox.

Then I reset it again but left Firefox open, and temporarily disabled all active Firefox extensions (some can interfere with settings, apparently). Then I re-enabled the extensions one at a time, restarting Firefox each time (& restarting it again for good measure). Throughout all this, my homepage setting has stayed set. Go figure! (I can't).

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 7 simple tips to get more out of…