Google Earth

  Clapton is God 20 Apr 13
Locked

Since I updated to the latest version of Google Earth (7.0.3.8542), Street View fails to work.

Whenever I drag the little orange icon to a place on the map it goes to ground level view rather than street view.

Am I dong something wrong or is there a setting I need to alter?

O/S is Win 7.

  Fruit Bat /\0/\ 20 Apr 13

Usually if it switches to ground view then there is no street view available for that area.

I gave up on google earth and do it all from google maps now.

  Clapton is God 20 Apr 13

I know that street view is available for the area.

It's the area I live in and street view has always been available in previous versions!

  john bunyan 20 Apr 13

I am sure you will have updated your graphics drivers, but I had a similar problem a while ago and it seemed to do the trick.

  muddypaws 20 Apr 13

Clapton is God

That version Is working OK on XP. The only difference is that there are no grey ovals to move forward on. Just have to click ahead on the road. I haven't changed any settings.

  muddypaws 20 Apr 13

Does it state 'street view' top right after you have dropped the man?

Advertisement

This thread is now locked and can not be replied to.

Windows 10 Home vs Windows 10 Pro comparison: Here are the extra features you get in the Pro version

Behind the scenes at Silverstone, the 70th British Grand Prix: Hisense starts UK push with Red…

How Found created this skateboard, bike and parkour stunts-laden, single-take car ad

Apple Pay UK launch date, UK user guide and participating UK banks | Apple Pay to launch in UK on 1?…

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message