Google Desktop - not for Win98/Me

  Zak 19:01 18 Jan 05
Locked

Page 74 of PCA issue 116, March 2005

System requirements are incorrect by stating that Win 98/Me are suitable

From Google download site:

* Requires Windows XP or Windows 2000 SP 3+


click here

  Zak 19:20 04 Dec 05

.......to resolve

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

How to install MacOS Sierra on an older Mac: Get Sierra running on Macs & MacBooks from before 2009