Google - delays after hitting Search

  Sleeping Dwarf 18:43 08 Jul 04
Locked

Just recently after inputing data, when I click on Search or hit the return button, nothing happens for about 10 secs; after this time the search is processed. Previously when I hit search it was instant. This only happens on google. All other sites I use everything happens at normal speed i.e. the loading box appears instantly.

I have tried adware, spyware etc and have removed the google toolbar, to no avail.

  QuickHare 19:18 08 Jul 04

It could be that Google is actually searching during this time, but I thought it was faster. It might be just busy. I could be wrong.

  bremner 19:26 08 Jul 04

Google still OK for me - returns in a second.

  Gaz 25 19:28 08 Jul 04

Google fine for me as well.

Instant.

  Sleeping Dwarf 20:46 08 Jul 04

Don't think it is taking it's time. when the loading box appears at the bottom, it appears for a nano second and search results appear advising hwo quickly search took. e.g. last search google says its took 0.18 seconds. In reality before the loading box appeared it was about 10 secs. It is as if the command is taking this long to process, but for google.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…