Google Chrome now very slow to load

  stlucia2 08:47 AM 09 Oct 13
Locked
Answered

I'm using Windows XP fully updated, and I started using Chrome some months ago because of issues with IE7. Recently Chrome has been updated, and now displays on its Google home screen eight large thumbnails of sites I've recently visited. At the same time its initial loading has slowed down significantly, and it even locks up if I try to start using it before it's finished loading fully.

I've looked at the settings to try and find a way to disable the thumbnails, in the hope that this will speed up the loading, but can't find anything. In fact, I realise now that I don't even need to use the Google Search screen as my home page because Chrome's address bar doubles as a Google search bar. So how can I achieve a blank home page, so it doesn't waste time loading history?

  stlucia2 10:39 AM 09 Oct 13

Yes, that's my version Jock1e.

Thinking about it a bit more, I have two choices but can't find either one in the setup menus: One is to change my Chrome home page to something other than Google -- perhaps even a blank page; the other is to configure the Google page so that it doesn't show the recent history thumbnails. That's on the assumption that it's the thumbnails that are slowing things down.

  alanrwood 11:30 AM 09 Oct 13

Todo that go into Chrome settings and set the home page to "about:blank". That will give a blank log on page but those stupid links will still appear on any new tabs.

  stlucia2 11:55 AM 09 Oct 13

I've gone into settings (in the drop-down menu that appears when clicking on the three horizontal bars at the top right of the screen), but there's no option for setting the home page -- I can only find an option for setting the home button, and changing that, or disabling it, doesn't make any difference.

  Batch 12:46 PM 09 Oct 13
Answer

to set home page as about:blank

Go to Settings

2nd item down screen should be "On Start-up"

Select Open a specific page.....

Click Set Pages

For Add A New Page, in the box enter: about:blank

Click OK and exit Settings

  Batch 12:51 PM 09 Oct 13

you could also try clearing your browsing history to speed things up

Start Chrome

hit CTL+SHIFT+DEL at the same time

in the box that comes up I do the following:

Obliterate the following items from: The beginning of time

And I have ALL of the boxes checked.

You may choose not to be so severe - it's your choice.

  spuds 13:56 PM 09 Oct 13

If Google Chrome is beginning to get slower, then perhaps do a Start-Up check with CCleaner (if installed), and see if that finds anything. CCleaner wil also check all other browser Start-Up and perhaps running problems?.

  stlucia2 20:01 PM 09 Oct 13

Thanks for the walk-through Batch. I've in fact set my home page to Google.co.uk, which is what I'm used to. Startup is back to normal now.

Before I changed it, the page listed was Google.co.uk but with a / and a long string after it; thinking back, I remember now that a recent ZA update forced me to make ZA the default browser, and I think that's when things started to go wrong.

I'd already used Chrome to clear all history. I use CC to clean up and check for issues quite regularly.

Advertisement

This thread is now locked and can not be replied to.

How to get free stuff for Android: Amazon Underground offers genuinely free Android apps and free…

1995-2015: How technology has changed the world in 20 years

MIT builds an awesome 3D printer that can use 10 materials at once

What to expect at the September Apple event: Apple announces 9 September event, sends out invites