games are giving me problems

  filthpig 15:28 23 Apr 07
Locked

i had a game installed on my computer and it wasnt working, the game was oblivion and i was getting an error message something like this:
the application has failed to launch dxd39.dll is missing
i ran dxdiag and there didnt seem to be any problems
recently i formatted my drive and i installed a different game: call of juarez whixh i then got the aformentioned message with juarez even though i worked fine before
now oblivion works fine but this other game doesnt
i have no idea what is wrong coz i have a decent video card and my system is fine with any other gaems
any advice would be great thanks

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

New Corel ParticleShop plugin now available: 11 new brushes & 6 new brush packs

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…