FYI - USB problem finally resolved ... I hope!

  cocteau48 12:34 20 Oct 09
Locked

From my previous thread click here
and also from the thread posted by electroplater click here

I was finding that the various solutions and workarounds had only a temporary effect and that the "this device could work faster if connected to a USB 2 port" would eventually return.

I think that I have found that following the instructions here :click here and uninstalling the "ghosts" of all previously installed devices or devices previously plugged into a different port has solved the problem and it seems to be permanent.

Hope it may be of some use to anyone who did not know about it.

  lotvic 14:54 20 Oct 09

Thanks cocteau48
that's cleared up a mystery (and prob) for me :)

  bathjobby 12:10 14 Nov 09

cocteau48, lotvic, are you both still free of the USB faster message ? I got excited when I came across this today as I have been trying to resolve this for ages. Did what was advised, dozens of not connected, previously used ghost devices listed, deleted them all and the enhanced USB, restarted, enhanced USB detected and reinstalled, but, still got USB faster message when starting usb device. Argh.
I used UVCView.x86.exe to view my USB ports when I switched the device on and saw it connecting to a non Advanced port. To be honest not sure what I'm seeing there as there are 6 Enhanced ports and a whole bunch of other non enhanced, yet I only have 4 physical sockets on my laptop. I have a backup disk that connects ok (without the message) whichever socket its put in. Oh well, just live with the annoyance I guess.

  cocteau48 12:31 14 Nov 09

Delete absolutely everything under USB ports in device manager. (if you are using a USB mouse you will lose that as well so you may need a PS2 mouse)
Reboot and let Windows replace what it wants to.

Now plug in your USB devices one by one.

That has worked for me but interestingly I also have one (of two) ext HD which never throws up the message.

  bathjobby 12:54 15 Nov 09

Thanks for the quick reply cocteau48, done exactly that and XP reinstalled the drivers on reboot but still have the problem. The device is an HP scanner, Scanjet 4850 which is stated as USB2, but whichever of my 4 usb ports I connect it to it never showes as connected to my USB Enhanced Host Controller, it always connects to one of the ports on the USB Open Host Controllers and hence the 'usb device faster' message. Yet whichever of the 4 usb ports I plug my Maxtor external disk to it always shows as connecting to one of the 6 ports listed under my USB Enhanced Host Controller. Oh um, maybe I'll just ignore it or turn the USB messages off but I just hate things that don't work properly. Thanks again though.

  bathjobby 14:40 15 Nov 09

Just did 2 more things; unchecked the 'allow windows to power off' usb hub option, made no diff. Plugged my maxtor into one of the 4 usb sockets and saw it become active on port 5 of 6 under the Enhanced USB controller, it registered as 'Current Config Value: x01 -> Device Bus Speed: High'. Connected the scanner to the same usb socket and saw it become active under port 2 of 2 on one of the 3 USB controllers (the non enhanced ones), got the USB device faster Msg and it registered as 'Current Config Vale: 0x01 -> Device Bus Speed: Full.
So the disk says High speed and the scanner says Full speed, if that means anything to anyone. Otherwise, I now give up.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

New MacBook Pro 2017 release date, UK price and tech specs: Kaby Lake MacBook Pro to launch in…