FX5200 won't work on xp

  johnpr 13:55 04 Aug 04
Locked

I have just upgraded my MX440 64mb to a FX5200 128mb graphics card, however when I attempt to load the new drivers the screen goes blank and I have to re-power.

I have tried removing the device and drivers etc. but the screen still goes blank.

When I put the MX440 back in it works fine

Any ideas?

XP1800 AMD
786 sd-ram
XP Pro

  Faser 14:09 04 Aug 04

Did you remember to remove the MX440 64mb in Device Manager before installing new card/drivers?

  Faser 14:13 04 Aug 04

This link has more info click here

  johnpr 15:16 04 Aug 04

Yes Fraser, I have removed the mx440 in device manager, when I reboot it finds the FX5200 as a new device.

When I attempt to load the drivers it tends to get to approx. 55% then freezes, then the screen goes blank.

  Faser 17:51 04 Aug 04

I think both cards use nVidia chips so you shouldn't be having a problem, how about using the original driver with the new card and then updating from the mnf. website? Or rebooting after fitting card in safe mode?

What make and model is the motherboard and/or how old.

Please don't be offended, but when you say it goes blank and freezes how long do you give it as it can take a while to stabilise after the driver Cd stops

  carver 21:51 04 Aug 04

When you fit the new card which drivers are you installing, because the latest drivers from Nvidia can cause some PC's to freeze when attempting to install them.

  jonnytub 21:55 04 Aug 04

are you cancelling the found new hardware wizard?

  jonnytub 21:56 04 Aug 04

here is the latest driver for all geforce cards click here

  keith-236785 22:25 04 Aug 04

sorry not much help, but just so you dont give up, i am using a FX5200 128mb Nvidia card with Win XP Pro. i didnt have any problems installing it, maybe i was lucky.

start from afresh, goto device manager, click display adapters, right click on the mx440 and choose uninstall. exit device manager

shut down pc

remove mx440 card and replace with the FX5200 card

restart computer and let windows install the default driver for your new card.

then follow the link from "jonnytub" to get the latest drivers. once downloaded, double click to start the install.

best of luck and i apologise if you have already done all this.

  jonnytub 22:27 04 Aug 04

also make sure any trace from add/remove programs is banished.

  carver 22:42 04 Aug 04

can you tell us just which drivers you were trying to install

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Method Studios' title sequence for BBC series Taboo is truly unsettling

Best Pages for iOS tips | How to use Pages for iPad & iPhone: 6 simple tips to get more out of…