Further problems with graphics driver installation

  Fleetblue 10:06 25 Feb 10
Locked

I posted a couple of days ago about my OS not being recognised and the advice I received was to update my Graphic card drivers. Unfortunately I now seem to have further problems. This is what I posted previously.

I have:
Windows Vista Home Premium 32 bit
Intel(R)Core(TM) 2 Duo CPU [email protected] GHz
2.00 GB RAM
NVIDIA GeForce8800 GT

Right step by step here is what I have done.

1 Uninstalled my current drivers and rebooted.
2 Went to NVIDIA site and ascertained that I should download 196.21. Did this saving download.
3 I then noticed that Windows Update had automatically installed graphics drivers.
4 I ran and installed the 196.21 drivers and rebooted but then had all sorts of problems. Crashes due to nvldmmkms.sys failing and then recovering, and then finally BSOD.
5 Thinking this might be a conflict between the Update installation and 196.21 I turned off automatic updates, booted into Safe Mode and uninstalled the drivers. I used Driver Sweeper to clean out all residuals and rebooted.
6 Lo and behold Windows Update automatically installed new drivers despite automatic updates being turned off.
7 Carrying on regardless I reinstalled 196.21 with same results as in (4).

Following the advice given by Rahere and gengiscant I thought I had solved the problem. Unfortunately fairly soon (4) was back.

Rightly or wrongly I came to the conclusion 196.21 was not right for my system. I uninstalled it in Safe Mode, used Driver Sweeper, then rebooted. Now despite me changing my Update settings to ensure that Windows checked with me before doing anything I got a message saying Windows had partially installed new drivers and did I want to finish the installation. I clicked “ask me again later”, but to me “partial” means that something has been installed. Having downloaded Drivers 195.62, I started to install them but got a message saying “Setup could not find C:\Windows\System32\NVCPL.dll”. I clicked OK, and then got another message saying “Setup could not find C:\Windows\System32\NVMCTRAY.dll”. Again I clicked OK and driver installation went ahead. When I rebooted drivers were installed but is something missing ref. the above messages? Once again (4) happening but not so often and so far no BSOD.

To be honest I am now pretty p’d off with the whole thing. It’s not just the “nvlddmkm.sys stopped responding and has now recovered” thing. I know that’s being an ongoing issue since around 2007 and there is no definitive fix. It’s the whole deal. I get messages saying “backup has failed”, my OS isn’t recognised etc. I’m seriously thinking about taking the “Restore factory settings” option, or using backup discs I made with OneCare. System Point Restore is no use as it only takes you back about 10 days max. Is this a final act of desperation or a viable option? Any opinions or advice very welcome.

  Graphicool1 10:21 25 Feb 10

Can you do a 'System Restore' to back before your OS wasn't recognised?

  Fleetblue 19:51 25 Feb 10

Hi Graphicool1. Sorry it's taken so long to get back to you. Unfortunately I had to go to work. System Restore will only take me back to 14/02/10 and I was experiencing these problems before then.

  Graphicool1 09:44 26 Feb 10

That is unfortunate, unless you happen to work at something you enjoy! Very few do.

I guess, when you got the BSOD, it flashed on and off before you could read the reason and fix instructions? Windows PC's are set on 'Auto Restart' by default. Anyway, as of now and your present state of mind I think that there is no mileage in putting off the inevitable.

What Anti-Virus and Spy ware are you using?

At this point I have to say that it is my gut feeling that your system has been infected and vandalised by a virus or a Trojan. If my suspicions are correct, after all you've been through so far the quickest, less painful and - although it may seem daunting - the simplest way to go, would be to reformat the HDD and do a clean install. That is the ultimate fix! But am to take it from your last statement regarding - "OneCare back-up disks" - that you don't have the 'Full Vista System' disk?

However it would seem more prudent to at least give the “Restore factory settings” a go first. After all, you don't really have anything to lose, but time. If you can stand the grief of it probably still not working right and still needing copious tweaking? But then you will still have the OneCare back-up disks as a safety net.

Which ever direction you decide to go, be sure to back-up all your important data on to another drive first. When you are eventually up and running again - yes you will be - keep the following somewhere safe. Make it one of the first things you do after everything else...

'Disable the Auto Restart on Vista'

Click 'Start' 'Control Panel'

Click on 'System and Maintenance' icon

Note: If you're viewing the Classic View of Control Panel, you won't see this link. Simply double-click on the System icon and proceed to Step 4.

Click on 'System' icon

Click 'Advanced System Settings'

Under the heading 'Startup and Recovery area and click on the Settings button.

In the 'Startup and Recovery' click 'Settings' button
Under heading 'System failure' un-tick the box next to 'Automatically restart'

Click 'OK' in that Window

Click 'Apply' then 'OK' in the System Properties window.

In the future if you should be unfortunate enough to experience another BSOD the PC will not automatically reboot. Giving you the time to read the message and if not acting on it yourself, telling us so we can guide you through it.

  Fleetblue 10:29 26 Feb 10

Thanks for all your help Graphicool1. Looks like the inevitable. I had Windows Live One Care but recently I was having trouble with that as well, and bearing in mind its imminent demise I uninstalled it and am now running Microsoft Security Essentials. Vista was already installed but I do have a "Reinstallation DVD for Windows Vista Home Premium 32 bit" Disk. Is this the "Full Vista System" disk? I have also a load of back-up disks made courtesy of Windows Live One Care, and various other disks I received with the PC including a Graphics Driver and Driver and Utilities disks.

  MAJ 10:42 26 Feb 10

I haven't read your other thread, a link would have been useful, so I can't imagine how updating your graphics card drivers has anything to do with an "OS not being recognised" problem. Has that problem been recified? Is this a new card or has it been working properly until now? Was it the card that came installed in your PC?

  Terry Brown 10:56 26 Feb 10

Try This
Restart your computer in SAFE option (usually F5 or F8) , select VGA mode.
This will start your computer with NO graphic drivers.
Go to the Nvidia site and select option 2 ' Let nvidia find the drivers for your computer'.
Download and install drivers, you may get motherboard drivers as well as Graphic drivers, if so download both.(Motherboard first)
Restart your computer as normal, and the new drivers should become the default setting.
Terry

  Graphicool1 15:44 27 Feb 10

"Reinstallation DVD for Windows Vista Home Premium 32 bit Disk. Is this the 'Full Vista System' disk?"

Sounds like it could be the disk I am talking about, did it come with the PC? As it seems to be the trend these days not to ship the disk with the PC. Instead they tell you - the buyer - to back-up the OS.

Before you take any of the plunges we've already discussed. I have a few tweaks here you might - if you haven't already - want to try? You have nothing to lose and everything to gain. First...

Click on 'My Computer'
Right click C: (your OS drive)
In menu click 'Properties'
Click the 'Tools' tab
Under 'Error Checking' click 'Check Now'
click the box next to...
'Automatically Fix File System Errors'
Click 'Start'
A notice will say it can't do it until the next time you boot. Click 'Yes' and reboot.

  Fleetblue 19:04 27 Feb 10

MAJ. The graphics card is not new it came with the PC and up until January I was having no problems with it. Then I began to get the "nvlddmkm.sys has stopped responding but has recovered" message. I've tried many solutions posted on various sites to cure this problem and this has involved downloading and installing different drivers, uninstalling them and trying again etc. At first this affected only my gaming but now my PC is crashing with this error on a regular basis and I end up with BSOD. To me it seems like a driver problem because when I uninstall the drivers and prevent updates from fully installing their own drivers I don't seem to get it. Which leads me to:
Terry Brown. I have Vista Home and I can't find VGA Mode on it. I'd like to be able to prevent Windows updating drivers automatically so that I was working with a clean base. Is there any way to do this in Vista Home.
Graphicool1. The disc came with the PC. I'll try the tweaks and let you know what happens.
Once again thanks to all for your help.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…