Further help needed with wireless connectivity

  wobblymike 20:44 28 Nov 05
Locked

Guys - last week a number of you and particularly Fruit Bat /\0/ helped me with a wireless connectivity problem - I still have a problem and hope someone can help. This is the situation.
I bought and fitted a 802.11b wireless pci card to my master pc (it is connected via ethernet cable to a router) this card seemed to set up fine,
I bought and fitted a 802.11g card to my slave PC which I want to use to share my broadband connection it caused the PC to freeze after a couple of minutes. I switched the cards around but could only obtain "limited or no connectivity".
Q1 - will the 802.11b card and the 802.11g card talk to each other?

Q2 - My conclusion is that the 2nd card must be faulty - what do you think?

  ade.h 21:12 28 Nov 05

AFAIK, 11b and 11g are not interchangeable unless you use devices that happen to support both, such as your typical Centrino laptop.

  Fruit Bat /\0/\ 21:31 28 Nov 05
  tasslehoff burrfoot 21:33 28 Nov 05

'g' card should (normally) be backwards compatible with the 'b' card.

IME the 'limited or no connectivity' has been related to an IP problem.

how are you assigning IPs? Are you using the router as a DHCP server? Or are manually setting them?

Is the connectivity message coming from the 'g' card?

  wobblymike 06:38 29 Nov 05

Guys Thanks for the responses - confusing or what

Tasslehoff Burrf - I'm not sure what I'm doing - the b card semms to set itself up ok but the g card crashes the PC as regards assignng IPs, this message does come up when I try to repair the connection - I confess I don't really understand it - how do I assign an IP address?

  mgmcc 08:30 29 Nov 05

Normally, with a router, both PCs would connect directly to the router, either by cable or "wirelessly", and there would be no direct link between PCs.

Presumably, your router isn't "wireless" and therefore you are trying to set up a separate "Ad Hoc" wireless network to share the broadband connection?

To do this you need to enable "Internet Connection Sharing" on the ethernet connection to the router. This will automatically configure the Wireless Adapter with the fixed IP address 192.168.0.1 and subnet mask 255.255.255.0

To enable “Internet Connection Sharing” in Windows XP, open the Network Connections folder, right click the actual internet connection (modem connection), select Properties and then the Advanced tab. Tick the box “Allow other network users...etc”.

The TCP/IP settings for the Wireless Network Adapter in the "client" PC are set to get the IP address automatically, which it does by DHCP (Dynamic Host Configuration Protocol) from the "host" PC.

If you are using Firewall software, it needs to be configured in its "trusted" area to allow access to the networked computers, usually by entering their IP addresses. Additionally, if using Zone Alarm in the "host" PC, the Internet Zone Security level must be reduced from High to Medium or ICS traffic will be blocked.

The other issue is that, because you are using Internet Connection Sharing, the two Wireless adapters will be using IP addresses in the 192.168.0.xxx range - the host fixed and the client by DHCP. As the router also has an IP address and allocates the IP address by DHCP to your "wired" ethernet adapter in the "host" PC, this separate network needs to use IP addresses in a different range or there will be a conflict. It needs to operate in a range with the third part of the IP address (the third "octet") a number other than the "0" used by the "wireless" network. This may already be the case, depending on the default IP address of the router.

The ideal solution, if the router isn't "wireless", would actually be to plug a "Wireless Access Point" into one of its LAN ports which would convert it into a Wireless Router.

  wobblymike 11:35 29 Nov 05

mgmcc
Thank you for your very comprehensive response, I will have a go this evening when I get home and post back how I get on. Thanks again.

  wobblymike 19:43 29 Nov 05

To enable “Internet Connection Sharing” in Windows XP, open the Network Connections folder, right click the actual internet connection (modem connection), select Properties and then the Advanced tab. Tick the box “Allow other network users...etc”.

I have tried to do this but when I right click the lan connection I only have configure as an option and can't find the option to allow other network ------etc I'm struggling any help appreciated

  keewaa 19:50 29 Nov 05

This might help click here

  wobblymike 20:35 29 Nov 05

keewaa
Thanks bit is the same problem can't identify this ICS option
Anymore advice - I confess I am finding this most frustrating.

  mgmcc 21:54 29 Nov 05

When you right click the Local Area Connection and select Properties, a box opens with two tabs - General and Advanced. Click the Advanced one and there should be an "Internet Connection Sharing" section with a box to tick "Allow other network users ...etc".

However, this option is ONLY available if Windows finds an available network adapter that can be used to connect to another PC. If you are trying to enable it on your Local Area Connection (which connects to the router), Windows must find a second network adapter, either a "wired" one or "wireless", before the option to share it is available.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac