Fujitsu Amilo Pro 3515 Will Not Boot Into BIOS

  sydhall 18:28 PM 01 Sep 11

Hi, Fujitsu Siemens Amilo Pro 3515 ? can anyone help? Granddaughters Lap will not boot up? The On switch light comes on with the wireless light: But the wireless light stays on and it will not go into BIOS?

  T0SH 19:51 PM 01 Sep 11

Try unplugging any USB devices and removing the power connector then remove the laptop battery (for now leave it out) ,replace the power connector and try to power on the laptop, with a bit of luck and a following wind it may get you going, the next move would be to try again with the battery fitted if all of the above fail it could be a hardware issue

Cheers HC

  sydhall 20:17 PM 01 Sep 11

HC; Have already done as you have suggested: NO luck

  Fruit Bat /\0/\ 22:21 PM 01 Sep 11

Remove hard drive see if it will boot to error message

  sydhall 08:54 AM 02 Sep 11

Fruit Bat /\0/\

Already Tried:

  birdface 09:24 AM 02 Sep 11


You certainly are not having much luck with laptops at the moment,I counted 5 threads that you still have open and this one I believe for the same computer.

I don't suppose it will go into Factory recovery will it.

Not sure if that would be F10 or not.

Obviously not your back light as you tried with an another monitor.

  Fruit Bat /\0/\ 10:03 AM 02 Sep 11

Remove BIOS (CMOS) battery for 10 mins, refit retry to boot.

  finerty 14:10 PM 02 Sep 11

remove the battery and power supply and press the power button for about 2 mins then reconnect the power supply battery and see if it boots.


This thread is now locked and can not be replied to.

Toshiba dynaPad release date, price and specs: Another Surface Pro 4 rival with Windows 10

1995-2015: How technology has changed the world in 20 years

Google Maps for web gets a Material Design-inspired makeover

New Apple TV 2015 release date and UK price: buy from Apple in late October, in store in November