Fresh XP Installation - Boot Drive M not C

  compumac 13:27 20 Jun 10
Locked

I have just purchased a new hard drive today and re-installed Windows XP. I have not installed any other programmes as yet. I now find that the boot drive with Windows on it is labelled M. I have noted other links on the forum in respect of this but these appear to be with regard to an already installed system being used, with a suggestion that the it is inadvisable to change the boot drive letter unless it was to change it back to what it was in the first place. I have other PC's that are networked and have links to this PC and I would have to change all of those links to ensure that they communicate as before. If my only option is to reinstall, then so be it, but I do not recollect dialogue box asking for the drive letter to be used in the first place. Is there any way I can just change the M to C?

  compumac 13:39 20 Jun 10

I should add that there is only the one hard drive installed but obviously Windows is seeing my builtin card reader as eight others. I think that from other threads it would seem that a re-installation of XP is the best way forward. Any suggestions?

  Graphicool1 13:40 20 Jun 10

click here and scroll down.

  compumac 13:54 20 Jun 10

Graphicool1
Following that thread only indicates that "Windows cannot modify the drive letter of your system volume or boot volume"

  VoG II 14:10 20 Jun 10
  compumac 14:16 20 Jun 10

Tried using Partition Magic to change drive letter to C - as expected and predicted - will not now boot. Oh well back to the drawing board.

  Fruit Bat /\0/\ 14:25 20 Jun 10

1. Make a full system backup of the computer and system state.
2. Log on as an Administrator.
3. Start Regedt32.exe (or Regedit.exe in Windows XP).
4. Go to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

1. Click MountedDevices.
2. On the Security menu, click Permissions.
3. Check to make sure Administrators have full control. Change this back when you are finished with these steps.
4. Quit Regedt32.exe, and then start Regedit.exe.
5. Go to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

1. Find the drive letter you want to change to (new). Look for "\DosDevices\C:".
2. Right-click \DosDevices\C:, and then click Rename. In Windows 2000 you must use Regedit instead of Regedt32 to rename this registry key.
3. Rename it to an unused drive letter "\DosDevices\Z:". (This will free up drive letter C: to be used later.)
4. Find the drive letter you want changed. Look for "\DosDevices\M:".
5. Right-click \DosDevices\M:, and then click Rename.
6. Rename it to the appropriate (new) drive letter "\DosDevices\C:".
7. Click the value for \DosDevices\Z:, click Rename, and then name it back to "\DosDevices\M:".
8. Quit Regedit, and then start Regedt32 (not required in Windows XP).
9. Change the permissions back to the previous setting for Administrators (this should probably be Read Only).
10. Restart the computer.

  compumac 19:19 20 Jun 10

Unfortunately it will not boot up even from XP CD/DVD.

  Fruit Bat /\0/\ 20:23 20 Jun 10

Do you have a fopply drive?
It takes just one floppy disc,

First format a Floppy disc

Run type
Format A: /u

Then open Notepad and copy and Paste this

[boot loader]
timeout=-1
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="First harddisk, first partition" /sos
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="First harddisk, second partition" /sos
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="First harddisk, third partition" /sos
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="First harddisk, fourth partition" /sos
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Second harddisk, first partition" /sos
multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Second harddisk, second partition" /sos
multi(0)disk(0)rdisk(1)partition(3)\WINDOWS="Second harddisk, third partition" /sos
multi(0)disk(0)rdisk(1)partition(4)\WINDOWS="Second harddisk, fourth partition" /sos
C:\="Previous Operating System on C:\"

Save as

in Notepad as BOOT.INI

Then in search find

NTDETECT.COM
NTLDR

Add these to the floppy disc


you can now try starting your computer with the floppy disc

  Strawballs 20:51 20 Jun 10

I had the same problem when I put new drive in daughters machine the main drive is now J and the slave drive became C I just left as it was others on network still see it ok

  compumac 10:04 21 Jun 10

Fruit Bat /\0/\
Thanks for that. I had completely forgotten about starting with a floppy to access the CD drive, it had disappeared back in the mists of time, plus it took me quite some time to find my floppy drive which I eventually found in the loft along with a number of Bootable floppies. Have now been able to install XP, BUT it hs now installed to 'I'. Whereas this is not really a problem by itself it does mean that all te other PC's on my network have to be informed of that change. I can see that having an internal card reader could have caused the change of drive letter, however it is only a few days previously that I had installed another hard drive in the same machine albeit with a lesser capacity, but it did install to 'C'. I did not see in the setup process for installing XP an option to choose a drive letter.
Any comments on that as I would still like to install to 'C' for general conformity.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

iPhone 9 and beyond: 32 amazing future smartphone developments - graphene, supercapacitor…