Freecom Extermal Hard Drive Not Recognised

  mds12 09:22 17 Jun 06


I have just bought a Freecom 80GB external Hard Drive and when i plug it in, it is not recognised....anywhere, not even in in disk management. The green light is on and i have attached the power USB just in case. I phoned up Freecom who were most unhelpful "just send it back to Amazon". They said i don't need the disk just plug it in. Could there be a problem with formatting or something??


  Diodorus Siculus 09:36 17 Jun 06

If disk management doesn't see it after a reboot, have a look in the device manager. If it's not there, then you do have a problem with the drive so should return to Amazon as soon as possible.

Speak to Amazon - they have an excellent returns policy.

  mds12 09:59 17 Jun 06

Thanks for replying but this is the second on in a week. Surely they both can't be faulty!??

  Taff™ 10:39 17 Jun 06

It`s possible because Freecom use various manufacturers hard disk drives - there might be a faulty batch. If I were you I`d simply try it on another computer. I presume you`re on XP?

  powerless 10:52 17 Jun 06

You have tried it in a known working USB port?

  mds12 14:44 18 Jun 06

Thanks for your replies. Can't get to another PC until Thursday (that runs XP) so guess i will have to try it then. If it does work on another PC anyone know where i go from there - i have tried it on a known working USB port

  Supertramp 14:53 18 Jun 06

Hi mds12

I trust you have installed the drivers. I had the same problem a few weeks back after I carried out a format of my hard drive.

Unplug the drive whilst the PC power is off switch on PC and plug drive back in, insert the driver CD and the drive should then point to the CD drivers, double click the icon and drivers will install.

  Taff™ 06:00 19 Jun 06

Drivers shouldn`t be required for XP - Freecom put drivers on the CD for 98SE.

  wee eddie 08:15 19 Jun 06

I phoned up Freecom who were most unhelpful "just send it back to Amazon".

Why not do just that. If they are happy with that solution

  mds12 19:38 19 Jun 06

Thanks for all your comments. I may have to send this one back too. I wrongly thought there may be something simple that i have not tried although when i did what 'supertramp' told me, it seemed to be trying to do something - at least the red light flicked on for a...nano second. Cheers anyway.

  wee eddie 20:01 19 Jun 06

It is just possible that you have insufficient power from your USB Port.

How many other USB devices have you plugged in to your USB Circuit?

This thread is now locked and can not be replied to.

Apple Event as it happened | Apple October Event live blog: Apple unveils new MacBook Pro at…

1995-2015: How technology has changed the world in 20 years

Graeme Messer's exhibition aims to challenge fears and insecurities

New MacBook Pro release date, price and specs | New MacBook Pro 2016 announced: Now with Touch Bar…