Found new hardware - printer

  Marko797 10:34 01 Apr 09
Locked

Everytime I start my desktop (XP Home) I get the above message. Thing is, the printer (HP 940C) is installed, connected and works fine already.

When I go through the new hardware wizard, it goes all the way through, then tells me it can't install the printer, even after me pointing it to the correct driver within XP??

Anyone advise what to do with this, and how I resolve it, please?

  Graphicool1 10:56 01 Apr 09

Unininstal it. Reinstall it.

  Marko797 11:17 01 Apr 09

cheers, had thought of that, but then what if it refuses to install (as per the found new hardware wizard not being able to install it)? I'd be well and truly stuck without printer.

  rdave13 11:25 01 Apr 09

Have a look here; click here

  provider 2 11:26 01 Apr 09

Or the HP site: click here

  Marko797 11:41 01 Apr 09

thnx, useful, but I suspect that applies to a printer connected via LTP, and not USB - which is how mine is connected. Don't want to make any wrong deletions in the reg.

provider2 thnx, but will need to read thru that one.

  rdave13 12:32 01 Apr 09

Try this, go to Device manager, view tab and select 'show hidden devices'. Expand 'printers' and see if there is a yellow exclamation mark. If so then right click, properties and check what it is then select disable. Try a reboot and see if the wizard has stopped and that the printer is working.

  Marko797 12:51 01 Apr 09

interesting. Did the above, and found 3 items with ! marks:
Non Plug n Play drivers as follows:
windrvNT
SABKUTIL

Under Printers:
HP 940c is listed, but below this is an unknown device. Can I safely delete this u think?

  Marko797 12:56 01 Apr 09

SABKUTIL is associated with Super Ad Blocker, which I have got rid of, and also windrvNT is associated with Folder Lock. Need to check these are fully uninstalled I guess.

  Marko797 13:08 01 Apr 09

Great news...situation resolved!
I rt clicked the 3 entries above, went to uninstall, then re-booted. No more New Hardware Wizard. Thanx to all for the (much appreciated) help.

  rdave13 00:47 02 Apr 09

Apologies I haven't replied earlier but just back from work. Glad it worked but I'd have tried disabling first instead of uninstalling. Just in case.
Thanks for the feedback.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

How VR is being used to simulate space

New iPad, iPhone SE & Red iPhone 7 on sale now