Folders disappear from view on networked AV player

  fazer4 10:51 AM 27 Aug 12

First things first, here is my set-up.
Windows 7 64 bit pc (2year old),
Netgear DGN2000 wireless modem/router,
Seagate GoFlex Home NAS drive,
D Link Powerline AV Network Kit,

D Link Powerline AV Network Kit,
Yamaha RX-V671 AV Amp,
Panasonic TX-P42V20B TV,
TP-Link 5-port 10/100Mbps Desktop switch,

From the first time I set this up I have had problems in seeing all the folders I put onto the NAS drive for streaming to my TV and AV amp. Half of my music folders From the letter K upwards simply disappear from the menu view on my amp after I switch it off then back on the next time I want to listen to it. When I check the NAS drive on my PC, all the folders are still there but are not accessable downstairs on the amp. I can re-transfer the "missing" folders and it's fine till I next switch off and on again and its always from the same point that the folders are missing. The TV is also suffering from the same problems when I want to view photos and videos which are present in the drive upstairs but not visible on the menu on the TV (all missing on the TV!) Everything is connected with cat6 leads and I can stream internet radio (which is built into the amp) without any problems so it seems to me to be a communication problem between upstairs and downstairs. My house wiring has all the sockets on one ring main so that should be ok but I wondered if the router was not up to it with it not being a gigabit router. A freind of mine has the same equipment and set up and his works fine (typical!!) I'm lost with all of this now and hope that someone can point me in the right direction of what to check next.
Thanks in anticipation.

  difarn 22:34 PM 27 Aug 12

Are the folders that you want to stream in your Public Folders? Do you need to enable Media Service on the Public Share.

I found this comment buried deep in comments on another forum that may help.

" I had assumed that enabling the NAS as a Media Server was sufficient and by so doing it automatically selected the media in the Public Share. It was a reasonable assumption because the Our Music, Our Pictures, and Our Videos folders were located there by default. That may have in fact been the case in earlier firmware versions, but now it is also necessary to designate which Share is the Media Service Share. That's accomplished by editing the Share's features. Simple!!

As soon as I enable Media Service on the Public Share, all of the media files were found and displayed in WMP, on my AV receiver and on my BD player. The music files in albums are sorted alphabetically vs. order on the album, but I can live with that. Now I'm finally getting the service from my NAS that I had intended."

Is the firmware for your NAS up to date?

  fazer4 18:02 PM 28 Aug 12

Hi difarn, Just to acknowledge your reply, I will check that advice out tomorrow when I get home and let you know the outcome.
Thank you

  difarn 18:55 PM 28 Aug 12

You're welcome - fingers crossed.

  fazer4 20:50 PM 03 Sep 12

Well, I've made sure all sharing boxes are ticked and loaded all my music into a folder i named and all my wifes music into a folder for her and all was fine for a while but inevitably the folders dissappeared from view again but the strange thing is, there are several default named folders in the go-flex, music, pictures, videos etc. and all the music appears in there despite my own named folders having gone.

I guess I will just have to use it that way rather than the way I wanted.

I needed to keep it simple for my wife to find her music instead of having to go through too many folders to get to her stuff, ah well, at least it works.

Thanks for the help and I'll leave this open for a while before I tick as resolved.


This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: Best UK Black Friday deals & best UK Black Friday tech…

1995-2015: How technology has changed the world in 20 years

HDR video: Everything you need to know

20 Mac Power User Tricks... That You Didn't Know