Floppy Drive Not Working

  Pete_W 19:33 20 Aug 04

Anyone know why my floppy's suddenly stopped working... I've upgraded the motherboard & cpu which entailed disconecting & reconnecting it... now it won't work? Will this disruption have done anything. I've tried the ribbon cable both ways (how do I identify the No1 pin on the floppy to red on the cable?)... makes no difference.

  Fruit Bat /\0/\ 19:43 20 Aug 04

No.1 pin red stripe usually close to power connector.

Check FDD floppy disk controller enabled in Bios and in device manager.

  Gongoozler 19:49 20 Aug 04

If the floppy ribbon is the wrong way round, the indicator light will be permanently on. It is quite possible that the ribbon has been damaged, so try a new one.

  THE TERMINATOR 19:55 20 Aug 04

If you have the cable fixed in the right way round(red stripe to the left side)check that the cable is plugged into the mobo ok....TT

  Pete_W 20:26 20 Aug 04

Thanks for the quick replies...
The indicator light is on with the ribbon in either position?
I wonder if disturbing the ribbon has cracked a wire inside... it may have gone brittle over the 4 years the last setup was in use?
I'll get a new ribbon & floppy tomorrow... they don't cost much & I'll let you know the result.
Thanks all

  Djohn 20:26 20 Aug 04

If you look at the IDE cable it splits in two parts at the end that goes into the drive, they are of an unequal size. Have the larger of the two nearest you as you look at the rear of the drive.

I would think though that your problem is more likely to be you have not enabled the drive, so go into your BIOS and enable the floppy, all should be fine then.

  Djohn 20:34 20 Aug 04

Our post crossed and I didn't see your last reply before posting. You didn't mention the light was staying on so forget my suggestion regarding the BIOS.

When you say you have tried the cable both ways round, do you mean you have swapped ends from the motherboard to the drive itself? If you read my post above regarding the split in the end of the cable then you will know if it's the right way round, as there are four possible ways of connecting it but only one will work.

  Pete_W 20:59 20 Aug 04

Tried the BIOS, it wasn't enabled... sorted that but the light was still on.
I swapped the cable for the new one that came with the board... fixed it! Why did i use the old one?... I dunno!
Thanks also to Fruitbat & terminator... I saved myself at least a fiver here!!!

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…