floppy disc asking to format and will not run

  pharte 14:03 16 Oct 05
Locked

I bought a new floppy disc with built in card readers (model Mitsumi FA402M FDD+7 IN 1 Read) and although all the lights etc are working it will not read a floppy or any cards.

If I double click it it asks me if I want to format the disc even though there is nothing in there, the same goes if I put any sd type cards in, it just asks me to format them.

Also when i connect my camera i do not get any options to copy the pictures to my comp which has only beem a problem since I installed the floppy.

The floppy did not come with anything as it was an OEM, I'm presuming that I need to download some drivers or the like.

anyone help ?

  keith-236785 14:18 16 Oct 05

how does this connect to the pc, is it via USB connection to a header on your motherboard, if so make sure you have got the connection block the right way around (also make sure you have hit all four pins, i couldnt get mine to work until i went back into the case and spotted i had missed one of the pins) easy thing to do as it was so fiddely in there.

on opening my computer, do you now have a few more drives in the removable drive section, i have now got 4 removable disks, since i got the thing connected properly.

if it connects via and external USB port then forget the above.

if your connection for the floppy is via the floppy cable then make sure its the right way around, if its wrong though the light normally stays on.

one last thing, check in the bios if the floppy drive is selected (1.44mb) sometimes it is set to NONE then as you can imagine, it wont work (but then it shouldnt be asking you to format either).

  Faser 14:34 16 Oct 05

What OS are you running; XP sp1 or sp2 normally would detect and install a device like this, even if you already have a floppy drive (It would call it Drive B)

If running XP have a look in "Device manager" for the Mitsumi FA402M, also double click "My computer" do the card readers show as drives. Have you used the correct cables and are they fully inserted?

There is a firmware upgrade for your unit on the Mitsumi web site here click here

  pharte 15:41 16 Oct 05

I'm running xp pro sp 2.
the drives are showing in my comp as is the actual drive.
the floppy was a direct replacement fot the original one and used the same cables etc along with the power lead and usb connector.
I'm thinking it must be a software / bios issue as neither the floppy or card readers will work.
I'm gonna check the bios now and do the firmware upgrade too.
the device manager shows standard floppy disc.

  woodchip 15:55 16 Oct 05

Go into BIOS. Make sure all USB are enabled

  woodchip 16:02 16 Oct 05

you could also try removing USB in Device Manager and then restart as the USB drivers it had running may differ from the ones now needed

  pharte 16:54 16 Oct 05

errr.... I have a total of 25 usb devices

1 x webcam camera
2 x standard enhanced pci to usb host controller
1 x usb mass storage device
1 x usb printing support
11 x usb root hub
8 x rev 5 or later usb universal host controller
1 x usb enhanced host controller

is this a lot ?

I haven't even got some things plugged in yet such as my pda, digi camera, external card reader etc.

I don't think I want to delete the usb stuff or will it just pick them up again with no problem.

  woodchip 17:10 16 Oct 05

All. Windows will reload when you start

  pharte 18:28 16 Oct 05

done the remove all usb devices thing....all reinstalled but no difference.
my digi camera is also unreadable and says the disc is full in properties (raw file) so I cannot even download any new pics from it, it still asks me to format it.
I even deleted the floppy drive and it reinstalled itself but without any difference.

I've sent an e-mail off to their tech support and I might hear something tomorrow.

the software download from the site will not work as it cannot find a device to flash to !!!!

  woodchip 20:59 16 Oct 05

Have you connected the Cable the right way round on the floppy drive split end to floppy and red tracer wire next to power plug on floppy drive

  pharte 21:37 16 Oct 05

definately ok with the cable, the ribbon will only go in one way (with the notch to the bottom) split end into the drive although the red tracer wire is on the opposite side to the power plug.
since I have done that which included pulling out the ribbon and making sure it was pushed home the drive light has stayed on (about 3 - 4 mins so far) since I restarted the comp.

by the way the ribbon I'm using is the multi plug one that is connecting all my drives together in sequence.

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…