Fizzy sizzling at the back of my monitor

  Zetra 16:55 24 Sep 10
Locked

The monitor I just bought makes a crackling sound if the power cable in the monitor’s end moves slightly, the sound only comes for where the plug is connected. Can someone explain why this happens?

  gengiscant 16:59 24 Sep 10

Faulty power point connection maybe,take it back.

  woodchip 18:30 24 Sep 10

This is very High Power Leakage, Thousands of volts. Take the Monitor back and get your money back. Hard to Cure Problem, as it's insulation Breakdown

  mooly 19:13 24 Sep 10

Sounds like a faulty socket or plug if that's where the noise comes from.

What's the make and model of the monitor just out of interest ?

  Garawa 19:24 24 Sep 10

Mine is a Dell and did that. A much firmer push (as I thought it was in all the way but clearly wasn't) and it's been fine since. That was 4 years ago!

Just do it with it all disconnected just in case it is the cable!!!! Woodchip, the cable THOUSANDS of volts???

  woodchip 19:56 24 Sep 10

no inside the monitor that creates the graphics raster Image

  johnnyrocker 22:00 24 Sep 10

does the picture fluctuate in any way during this incident? might it have got wet?



johnny

  Zetra 23:22 24 Sep 10

It’s a dell u2211h,
I tried using a different cable from my odd monitor, it didn’t seem to make any noise but when I pulled it out it made the same crackly sound from before. And that’s never happen with my other monitor.

Tried Garawa’s suggestion and that seems to have worked, I don’t hear any noise when the cable moves and I haven’t attempted to pull it out with it plugged in the wall.

Should I still send it back? The warranty offers a next day replacement for it.

@ johnnyrocker – I’m not sure if it affects the picture, I only noticed it when i was tidying the cables and I’m sure no liquid has gotten on/in there.

  MAT ALAN 23:27 24 Sep 10

Should I still send it back? The warranty offers a next day replacement for it.

Absolutely, no point in mucking about with it as you may do something that defaults the warranty agreement you have..

  peugeot man 06:01 25 Sep 10

It's most likely you had not fully inserted the mains plug into the monitor.
However you need to satisfy yourself that this was the case.

Try removing and then refitting again, you will almost certainly notice that there is a point where the lead is connected but there is movement causing the problems you describe, a final push will ensure the plug is locked in position and it wont move around .

  accordion 06:48 25 Sep 10

Send it back? Because you hadn't fully inserted the mains lead? Of course not.

Dave

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation technologies coming to Siggraph 2017

iPad Pro 12.9 vs Surface Pro 5