Firefox and PC Advisor

  hawthorn59 17:09 27 Dec 10
Locked

Hi folks

I've just started using my new Sony Vaio laptop, though I bought it before Christmas. When I tried to load the PC Advisor page it doesnt load completely, in Firefox 3.6.10 It is just a white background and text/links. It loads fine in Chrome and IE8. What can be wrong?

Also the laptop has McAfee Internet Security, Norton Online Backup, and Microsoft2010 Starter Edition.

I dont want any of these as Im using Microsoft Security Essentials, and I have a copy of Office 2007. How best to uninstall them? Use Add/Remove or use revo uninstaller? I seem to remember Symantec has an uninstaller on its site for unwanted software. Has Microsoft and McAfee got similar or will Revo do the job?

thanks

h

  rdave13 17:37 27 Dec 10

If you haven't clicked on any of the shortcuts on the desktop for Norton or McAfee, etc., then uninstall via programs and features should be good enough. Check your ad-ons in FF.

  961 17:38 27 Dec 10

MacAfee and Norton both have downloadable uninstallers to remove their software

Best to use those

Microsoft starter edition should remove ok via add/uninstall via control panel

Firefox is currently updated to 3.6.13. Update and then see if all the add ons have been downloaded

  spuds 18:49 27 Dec 10

Using the programs own uninstaller is suppose to be the correct to do it, but I find that Revo usually finds the 'little bits' that might be left over.

I have just tried the PCA website using FF 3.6.13 and it opens the pages okay, but a bit on the sluggish side. Normally I use IE8 on this site.

  woodchip 18:57 27 Dec 10

You will find it works faster if you switch off Java Scripting in FireFox options

  woodchip 18:57 27 Dec 10

You will need it for some other Sites

  hawthorn59 22:33 27 Dec 10

Thanks Im up to speed now on how the best way to uninstall.

However Firefox still wont display properly, there appears to be no images or colour. But its fine on IE and Chrome,also Ive just tried it on Firefox on my old laptop and it loads perfectly. Could it be something to do with this new Sony? Really hope not.

Final concern; it might be my imagination but I feel the Sony is running slightly sluggishly in comparison to the old HP. The HP is 3gig Ram and Amd dual core; the Sony is 4 gig ram and Intel Pentium p6100 dual core. Surely the new one shouldnt run slower? Could Symantec or McAfee have something to do with it? Im about to uninstall them now anyway.

thanks

h

  rdave13 23:51 27 Dec 10

If you've uninstalled McAfee and Norton (up to speed as you say..ugh..) then you have something else bogging you down, don't you think? Must be software related.

  hawthorn59 02:39 28 Dec 10

Yes McAfee gone, and Norton gone after a lot of effort. Again might be my imagination but seems to be going nicely now. And after a few restarts PC Advisor is loading normally!

thanks

h

  rdave13 02:57 28 Dec 10

Thanks for the feedback.
Always remember that on a new desktop on a Laptop or other, then NEVER click on a short-cut.
Always go to programs and features (add/remove in old XP) and choose uninstall. If you click on the initial short cut on the initial desktop folder then these software WILL install.

  woodchip 09:08 28 Dec 10

Yes but you still need a Anti-Virus

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced