Firefox keeps prompting for password

  spras 15:03 23 Oct 08
Locked

Firefox insists on showing a password prompt every time I log on to my companys intranet. IE does not, I believe becuase it has the intranet sites added to a list of trusted sites. While Firefox will remember the username and passwords by filling in the log in prompt the fact that it insists on showing it is incredibly annoying, is there any way to stop this behaviour?

  Halmer 15:26 23 Oct 08

then try changing the network.negotiate-auth.allow-proxies to false from true by double clicking on it.

You can always reverse it if it doesn't work.

  spras 15:36 23 Oct 08

No luck, was already set to true. I've also tried adding a URL to network.automatic-ntlm-auth.trusted-uris and network.negotiate-auth.trusted-uris to no avail

  Halmer 18:02 23 Oct 08

I think you have to change it to false

  spras 18:04 23 Oct 08

haha sorry I didn't read your first post properly, I'll try that when I get in to work tomorrow. Thanks for your help

  Halmer 20:30 23 Oct 08

good luck.

If it doesn't work, Google you problem and I'm sure you'll find a solution, particularly on the Mozilla Forum.

  spras 09:28 24 Oct 08

Still nothing unfortunatly.

I have tried:

network.negotiate-auth.allow-proxies - toggle to true

network.negotiate-auth.delegation-uris - adding a URL

network.negotiate-auth.gsslib - adding a URL

network.negotiate-auth.trusted-uris - adding a url

  Halmer 09:37 24 Oct 08

You could try the latest Beta version which I am using and is fine click here

It will install separately so you wont lose the version that you currently have.

  spras 09:31 27 Oct 08

Unfortunatly that hasn't solved it, but thanks for your suggestions so far.

I've narrowed down exactly what in IE is creating this behaviour (of auto login to intranet) - it seems FF either does not have this behaviour included or has it disabled by default (as it's a potential security risk if a desktop is left unlocked).

In IE if you go Tools>Internet Options>Security Tab > Select 'Local Intranet' > Click 'Custom Level' and scroll to the bottom > The 'User Authentification' section allows 4 options:

Anonymous Login - Gives me an 'Access Denied' error when selected
Automatic Login only in Intranet Zone (Default) - Allows this auto-login behaviour
Automatic logon with current username and password - Same behaviour as above
Prompt for username and password - Prompts regardless of whether username and password has been 'remembered' or not

I don't know if that will give anyone any ideas of how to alter Firefoxs settings?

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…