Firefox and Java – advice please

  sjbell 17:52 20 Dec 04
Locked

I've been using Firefox for about a week now. I notice that Mozilla recommend using Sun Java version 1.5.0 (click here) but on the main website (click here) they are still offering only 1.4.2_06. Is version 1.5.0 a final release or is it still undergoing testing? Which version would you recommend using?

  alan227 19:03 20 Dec 04

I use Firefox and have just updated to 1.4.2_06 and have no problems.

  Valvegrid 19:09 20 Dec 04

As alan227, go for 1.4.2_06 that is the most up to date, there is also another reason, there is a security problem with the previous versions which has been patch in this recent version.

  sjbell 20:50 20 Dec 04

Valvegrid
Isn't version 1.5.0 more up to date than 1.4.x?

  Valvegrid 22:58 20 Dec 04

Ah! Silly me, I didn't twig, sorry my fault.

What you are looking at there are two different animals, there's Java runtime (your first link) and Java Sun (your second link), they both do different jobs. I must say it does look confusing when they say Version: 1.4.2_06 and later then they go on to mention Java Runtime Environment 5.0 (1.5.0).

  sjbell 07:39 21 Dec 04

Thanks for your help. I'll use 1.4.2_06.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Prehistoric Britain is laid out in these Royal Mail stamp illustrations

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…