Firefox English GB Dictionary not working

  octal 21:51 29 Mar 07
Locked

If anyone has tried to install the English GB Dictionary on Firefox 2.0.0.3 you'll probably find it's not working, it says it's not compatible. The script for that file hasn't been updated, I have rewritten the script for it and uploaded it to my web site. Let me know and I'll post the link to it.

  bennyhillslovechild 21:58 29 Mar 07

I'm running it on 2.0.0.3 with no problems....maybe I just got lucky.

  octal 22:05 29 Mar 07

It sounds like you are lucky, there's a few other people who are having problems with it, all the other languages have been updated, but not the en-GB one for some reason, no doubt they'll realise and change it eventually. You can disable the extension compatibility check in about:config but it disables compatibility checking for all the extensions which can cause a problem.

  Stuartli 00:31 30 Mar 07

Do you mean the Preferred Language from the Advanced tab (via Tools>Options)?

If so, my language is still English {en}.

  octal 06:28 30 Mar 07

No, it's the Spellcheck add-ons associated dictionaries from here click here the English GB one hasn't been updated yet, it's still on version 2.0b1, I've changed the script to 3.0.

If you don't use Spellcheck or still use the American version you won't have a problem, I'm GB English and like my spelling to be as such.

  Stuartli 10:17 30 Mar 07

I'm still a bit confused - put it down to old age - as I also got the message that it is not compatible when visiting your link.

Yet Firefox's present spelling check works fine for me with 2.0.0.3.

  Stuartli 10:18 30 Mar 07

...and it's an English (GB) version.

  octal 11:27 30 Mar 07

That's interesting because when I upgraded to 2.0.0.3 it checked the compatibility and it threw my GB spellcheck dictionary as not compatible, that's why I had to dabble around with the one off the Mozilla site.

This is the one I dabbled with on my web site:

click here

  Gongoozler 12:22 30 Mar 07

I had the same problem when I installed Firefox 2.0.0.3 on my hard drive after a reformat. To solve it I used the manual method described by Pedestrian on this Mozilla forum click here. My C:\Program Files\Mozilla Firefox\ folder didn't have a dictionaries folder so I created one and copied the en-GB.aff and en-GB.dic files to it. After closing and reopening Firefox the dictionary was there. Hopefully as a result there aren't any spelling errors in this posting!

  octal 12:42 30 Mar 07

I saw that thread as well and did the same as you and copied both those files across, restarted and it still wouldn't work, I do use Linux that might be something to do with it, but can't imagine what. I even tried the other method by unpacking the file and editing the install.rdf file then resaving the file as a zip then renaming the zip to xpi, nope still wasn't having it, it told me it couldn't find the install file.
What I had to do in the end was to edit the install.rdf file within the archieve application and keep it as an xpi file, if that makes sense.

  €dstowe 13:22 30 Mar 07

I have British English Dictionary 1.19 installed in my Firefox 2.0.03 version. This is the same on all of my machines which have Firefox.

I was told when I installed the latest Firefox that the dictionary was incompatible and to go to Firefox Add-ons for a new version - which I did without any problems at all.

This thread is now locked and can not be replied to.

Sony Xperia XZ Premium review: Hands-on with the new 4K HDR phone with Motion Eye camera and Snapdr5…

1995-2015: How technology has changed the world in 20 years

Best laptop for design and art 2017: we test Apple, Dell, HP, Lenovo and Microsoft's best models…

CarPlay tips & troubleshooting guide: CarPlay tips & troubleshooting guide: Get the most from…