Files all read-only after Windows 7 installation

  jonmac 14:13 04 Nov 09
Locked

My primary HD is partitioned into C:\ for software and D:\ for data. After performing a full install of Windows 7 (from XP) all the MS Office 2007 data files on D:\ open as read-only files and have to be saved to another filename if changes are made. In the properties box for individual files they are not marked as read-only so I feel the answer to the problem is to do with "permissions" but cannot fathom out how to change the situation for individual files and folders. When I right-click on a file and follow through properties, security etc I am quickly lost as to how to proceed.
I'm the only user of the PC and presumably automatically the system Administrator. Can anyone help?

  BurrWalnut 15:19 04 Nov 09

To take ownership of a folder, right-click the folder, select Properties > Security Tab > Advanced at the bottom > Owner Tab > Edit > Highlight your username and put a tick in ‘Replace owner on sub containers…’ and Apply > OK. You will only have the ‘Replace owner on subcontainers…’ box for folders not files. Click Yes when you receive the Security pop-up window then click OK to the Close/Reopen message. Make a note of the previous owner in case you want to change it back.

Now go back to the Properties > Security Tab. Click Edit > Add. Type in your User Account Name in the box under Enter the objects name to select. Click on Check Names > OK. Click on your User Account Name to highlight it. Check the box for Full Control > Apply and OK etc.

Additionally, you may want to add Take Ownership to the right-click menu click here[2]=Networking%20Internet

  GaT7 16:00 04 Nov 09

This may be of some help too - from click here:

"To view or to remove the Read-only or the System attributes of folders in Windows Vista or Windows 7

1. Click Start, click Run, type cmd, and then press ENTER..
2. To view the syntax for the Attrib command, type attrib /? at the command prompt.

To remove the Read-only attribute and to set the System attribute, use the following command:
attrib -r +s drive:\<path>\<foldername>

For example, to remove the Read-only attribute and to set the System attribute for the C:\Test folder, use the following command:
attrib -r +s c:\test

Be aware that some programs may not operate correctly with folders for which the System attribute and the Read-only attribute are set. Therefore, use the following command to remove these attributes:
attrib -r -s drive:\<path>\<foldername>

For example, to remove both the Read-only and the System attributes from the C:\Test folder, use the following command:
attrib -r -s c:\test

If the Run command is not listed on the Start menu, do the following:
Click Start, click All Programs, click Accessories, and then click Run."

Also see click here. G

  jonmac 17:02 04 Nov 09

Thanks BurrWalnut for the reply. Unfortunately neither of your procedures work in my case. Don't understand why. They seem perfectly possible.
Crossbow7, when I click on Start there is no indication that I can see of any "run" choice as there was under XP. Any suggestions? Maybe I should just resign myself to saving under another filename, delete the first then rename the second with the original name for an easier life!

  GaT7 17:05 04 Nov 09

Try entering cmd in the Search box. G

  badhair1963 17:49 04 Nov 09

To get the "Run" command, right-click on the "Start" button and click "Properties" then "Customize". Then go through the list until you find the "Run" command. Tick the appropriate box.

  jonmac 00:00 05 Nov 09

Badhair1963, thanks for that advice. Got the Run option set OK and went through Crossbow7's suggestion but again to no avail. Bit of a mystery. I note that he backup copies of these files on the secondary and external HDs are not Read Only. Strange.

  jonmac 07:21 27 Nov 09

The solution adopted at the end of the day proved to be to ensure that I was Administrator, copy all folders and files in, say a "Data" folder to one called "Data2," then Delete the Data folder and rename the Data2 as Data again. Similar to Save-As with an individual file. Actually since most of my files are seldom re--used I'm sure I can live with the problem fairly well but it's annoying that Microsoft, who must be aware of the problem, haven't publicised it to avoid frustration.

  Triggers 20:51 04 Feb 10

Having tried various different methods suggested in this Helproom, I am still unable to remove/change an incorrect 'user'. I am running XP SP3. My laptop is called 'NETBOOK'. When I installed my system - Win XP was actually installed on purchase - I erroneously typed in as user "Ian Leckenbyn" rather than "Ian Leckenby". I accept that this is a somewhat minor mistake, but it is an irritation!
I have tried creating a new 'user' as Administrator, and re-booting. I still find the "Ian Leckenbyn.NETBOOK" folder/file in the Docs & Settings on my C:\ is "Read Only". I can 'untick' the RO box, and ammend the spelling, but I always get the message "Close any prog that may be using file & try again". I am unable to change the name.The suggestion to try "My Computer", "Properties","Advanced", "User Profiles", "Settings" (having created an earlier new account with Admin priviledges) and selecting the 'new' 'user' and 'Copy to' does NOT work - all options are 'greyed-out' though both 'Ian Leckenbyn' and the 'new' profiles are shown!
I cannot believe this cannot be 'sorted' in an easier manner? Any further help gratefully received! Many thanks - Ian Leckenby(n)

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Fresh New Fonts of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced