file sharing

  pennyminstrel 09:20 15 May 06

I have a belkin router with a one pc connected by cable, one connected wirelessly and a laptop connected wirelessly some of the time. The cable connected pc and the laptop work great. They can both connecta to the internet and both share files. but I'm having trouble with file sharing with the wireless pc. It can connect to the internet but when I try to share files i get the 'access denied' message. The cable connected pc can see the wireless one but not share files, the wireless pc can't connect to the nerwork at all.
I've turned on file sharing on both pcs and configured NIS. What next?

  Jazzy James 14:42 15 May 06

The most likely problem here is a firewall blocking access.

1. Windows has a firewall
2. The router will probably have a firewall
3. You may have other AV software with a firewall on the wireless PC.

Get these turned off to get the network set up.

Other things you could try would be to put a cable into the wireless computer to eliminate the wireless connection. I guess you have Mac filtering / WEP / WPA encryption on the router and this could also be causing a problem.

  ade.h 15:07 15 May 06

Quote "...and configured NIS"

Though whether it has been configured successfully, I would not like to conjecture.

You should not turn off a client firewall when configuring a workgroup, domain or other form of connectivity unless you intend to create all the required permissions manually. It is best to allow the firewall to prompt you for a response whenever a new permission or protocol needs to be created.

  ade.h 15:10 15 May 06

Could you provide information about the user accounts that each client has? I am looking for a relation between them. You may need to enable the Guest account on the problem client and assign it a password.

Could you also state whether each client has XP Home or Pro?

Could you run services.msc and check whether Simple File Sharing is enabled?

And finally, confirm whether the Network Setup Wizard (*not* the Wireless version) has been run on every client, with the default MSHOME workgroup name changed to the name that you had initially chosen?

  pennyminstrel 18:23 15 May 06

thanks for all your suggestions guys.

Jazzy James:
1. windows firewall is off
2. tried turining the router firewall off temporarily but it didn't help.
3. nothing else with a firewall on the pc
4.don't have MAC filtering on - tried playing with it but it got me in a mess with the pc that's working so got rid of it again. I do have WPA-PSK encrytion but it didn't cause any problem with the laptop.
5. In NIS i added the IP of the new pc in the trusted Zone but it didn't make any difference.

What info did you want about user accounts?
Each client has XP home
File sharing seems to be enabled in services.msc, altahough it wasn't called Simple File Sharing - sorry i'm getting into areas I barely understand here.
yeah I did run the network setup wizard on each client but I left the workgroup name as MSHOME. should i change it?

Just off to try enabling the Guest account on the other pc!

  Strawballs 11:07 16 May 06

You don't need to change the workgroup as long as they are all the same

  ade.h 16:42 16 May 06

Sorry that I have not replied sooner.

Firstly, Strawballs is correct; I don't expect you to change the WG name. Though you should be careful to type it consistently; although it appears as CAPS in the wizard, type it the same every time, such as all lowercase for example.

It may have been useful to know each account name, its type and whether it is passworded, but as you only have XP Home, this does not *usually* apply. In a mixed environment, it can and often does make a difference.

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…