Faulty PSU

  smiffyrebel22 16:58 21 Jan 09
Locked

I have a PSU that fires up the PC but there is no display on the monitor and the harddrive access light is permently ON, I have checked all the voltages at the ATX plug and they seem OK, I even have the correct voltages at the Sower OK PIN. If I put another PSU on the PC everything works fine , so it is definately a PSU fault. Anybody got any ideas what could be causing it.
Thanks
SmiffyRebel

  Fruit Bat /\0/\ 17:21 21 Jan 09

Voltage and load are two different things
Voltage can show OK until you apply the load of a drive for instance. You really need to test the PSU with a proper tester.

Often not worth or impossible to repair anyway, there can be some nasty voltages inside the PSU so DO NOT OPEN unless you are and expert.

  citadel 17:31 21 Jan 09

psu's die and faults occur, it's just what happens over time, depends how lucky you are is to how long one lasts.

  DieSse 17:50 21 Jan 09

"...got any ideas what could be causing it."

Yup - it's failed. It happens.

They're never worth repairing - switching mode power supplies are always hard to repair, and please heed FBs warning.

  smiffyrebel22 22:38 21 Jan 09

Thanks to everybody for their help, I am a electrician by trade, It just seems weird that I am getting all the correct voltages even when checking between 12volt positive and 12 volt negative I am getting a total of 23 volts wwhich is correct, but of course I have not checked it under load, I guess I'll just turn it into a bench psu and try a few load tests.
Once again thanks for your comments
Smiffyrebel

  woodchip 22:47 21 Jan 09

If you are what you say then you should know how to back probe a ATX Plug click here

  woodchip 22:48 21 Jan 09

With the Computer switched on. And plug connected to Mobo

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac