Faulty DVD drive or something more sinister?

  Maineman 17:54 01 Feb 05
Locked

I have a Pioneer DVR-104 with firmware 1.41 that is set as my primary slave drive. The set up has been the same without problems for some time, a CD RW as secondary master and hard drive as primary master, so CD - DVD are on separate IDE cables. The DVD drive is now causing problems in that when connected my system slows almost to a standstill, and when eventually in 'My Computer' does not recognize that a disk is in the drive. If right clicked it takes for ever and ever to reach the listed options and still shows no disk. It is shown as okay in device manager.It also ejects manually, responding to the push button. If I disconnect it the system works fine, loading quickly and responding well. Faulty drive I thought... but if in safe mode it appears to work fine, quick to respond and recognising disk content. I have tried another cable without success and changing to master but to no avail.
I have also reinstalled the chipset drivers and deleted the ide controller, but no joy.
Anybody have any ideas? I'm loathe to fork out on a new drive if it is something else, as I would expect it not to work in safe mode either!
Cheers.

  Fruit Bat /\0/\ 18:02 01 Feb 05

DVD struggling to read drives reverts all drives on IDE to PIO rather than DMA (slows everthing down)

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

  Maineman 19:57 01 Feb 05

Thanks for the comprehensive and interesting response. Unfortunately I've tried the regedit approach and device manager approach without success. It took bloody ages too because of the speed reduction that drive is causing. I also tried removing my CD drive (sec master) manually and putting the DVD in it's place....same slow computer. It must be the drive I guess. Final test will be to beorrow the CD drive from my lads PC and try that in the DVD rom's place.... then I'll have an idea I suppose. I just find it surprising that it will work in safe mode okay. I'll post my result anyway (won't be til tomorrow now). Thanks.

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac