FAILURE OF A SANDISK FLASH-DRIVE?

  marcanton 15:58 14 Aug 10
Locked

Hi

I have a problem with a SanDisk Cruzer Titanium 16GB USB Flash-Drive. I have been using it to download music, video and photo files from the internet. I received a pop-up message to tell me that the drive was almost full but I tried to download a large video file which may have exceeded the storage capacity of the drive. Since then my PC does not recognise the flash-drive at all, I have tried inserting it into different USB ports on my PC, front and rear, and on my laptop but it doesn't appear to be working at all. Is there any possibility of retrieving these files by purchasing additional 'rescue' software, or by using some other method you may know of?
Many thanks to anyone who could help me.

  ashdav 16:00 14 Aug 10

In disk management try changing the drive letter.
Worked for me once.

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Fresh New Fonts of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced