External hard drive- open with?

  colinthecamel2 11:07 22 Sep 07
Locked

I have an external hard drive on my laptop. It comes up in My Computer as E. I used to double click on the icon to open it. Now, when I double click the icon, it asks me which program I want to use. How can I revert back to just a simple double click on the icon to open it?

  mgmcc 12:17 22 Sep 07

What happens if you right click the drive's icon and select "Open"?

If that also gives the error, what happens if you display the folders in the left pane, expand "My Computer", so that the external drive is shown, and click on that (which obviously should display its contents in the right pane)?

  colinthecamel2 13:03 22 Sep 07

Hi If I right click the icon and select "open" then the drive opens as expected. It just would be easier if I could double click it like I used to!

  mgmcc 18:42 22 Sep 07

Try going into Disk Management ("Start > Run", type DISKMGMT.MSC and click OK) and allocate a different drive letter to the external drive. Then see if the new drive letter opens it when double clicked.

  Technotiger 18:53 22 Sep 07

Maybe a System Restore will fix.

  colinthecamel2 19:01 22 Sep 07

Just changed drive letter and opened My Computer. Double clicking on the icon still comes up with "open with what" menu.

I have also done a system restore recently but this failed to change things.

  Technotiger 19:26 22 Sep 07

Try running CCleaner click here in its default opening settings.

  cycoze 19:30 22 Sep 07

can you not just choose Explorer when offered "open with what", and tick the box to always use Explorer?

  colinthecamel2 19:43 22 Sep 07

Thanks for your help guys!

explorer is NOT present in the open with menu. Internet explorer is but not explorer. I can select explorer by using the browse function but I cannot tick the box to say always open with this program.

  cycoze 19:56 22 Sep 07

Nearest i can find to this problem is this click here but that came about after cleaning an infection.

  colinthecamel2 00:40 23 Sep 07

That seems to be the same problem that I have. Well done for finding that out! Sadly the solution does not work for me as I have no files called c:\autorun so I cannot delete them, nor do I have autorun.vbs anywhere to be found. The registry edit entry is also correct. Maybe I will just have to right click and Open from now on!

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…