External Hard Drive No Longer Recognised

  dublincity 21:53 25 Feb 05
Locked

I'm on XP Pro and successfully installed and used a new, USB2-connected Freecom External HD a few months ago. Following a few PC problems, it isn't now recognised. If connected up, the blue light flashes for hours at a time. Sometimes - but not always - the PC won't shut down or boot up if the External is connected.

I've tried the various combinations of uninstalling/reinstalling the software, shutting off the HD power &/or replacing the plug into the USB port - with the PC off and on, etc. I can't discover anything from Device Manager or Disk Management.

Any help will be gratefully received. Many Thanks.

  dogbreath1 21:58 25 Feb 05

I really do wish you luck. But if you search this forum (and my thread pertaining to a similar problem is not too far away) and other similar forums, the external hard drive not being recognised is a common problem. Another common thread is that the problem is not usually solved. Good luck anyway.

  kinger 21:58 25 Feb 05

Try uninstalling the drivers, just as if you never had the drive in the first place.

Go in to device manager and use the uninstall feature to get rid of it.

Then install the drive all over again and see if that works.

I did this for mine a few weeks ago and, although it gets forgotten by the OS every so often, it works most times.

  Technotiger 22:05 25 Feb 05

Hi, I know we always say there is no such thing as a silly question in this Forum - but perhaps this is a 'silly' response - I suppose you do have the drive connected to a usb2 port as opposed to usb1? Though I don't know even, if that would make any difference. Just a thought - silly or not.

Cheers.

  kinger 22:07 25 Feb 05

I think that you get a warning stating "This divice will run faster if you use a USB 2 connection" with a choice of available sockets.

That's MS technology for you.

  FelixTCat 22:10 25 Feb 05

Does it work on any other pc?

  dublincity 22:37 25 Feb 05

Thanks for all the comments. This PC only has USB2 ports and the External HD was working well until a few days ago.

[It's never worked on my old PC with Pentium I and USB1]

dogbreath1 - yes, I'd spotted that!

I haven't yet tried uninstalling the drivers. Am I right in thinking that they'll be re-installed automatically after a re-boot?

  Technotiger 22:40 25 Feb 05

Yes

  dublincity 23:16 25 Feb 05

Yes - I've uninstalled the drivers and, yes, they have been reinstalled after a re-boot. The 'Search For New Hardware' wizard then froze, requiring a re-set. The PC's the same but still not recognising the External HD.

  kinger 23:19 25 Feb 05

You will really need to try it on a friends PC to determine whether it's a faulty drive or a setting on your computer.

  Technotiger 23:25 25 Feb 05

Me again - a freeze such as you describe is sometimes caused by poor connections (even if they look good) - I would advise a thorough check of all connections, internal and external, and not just the drive, but especially your memory sticks - remove and replace, sometimes does wonders.

Otherwise try and check on another pc.

Cheers.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…