Excel - Align decimal points

  villageidiot 13:24 06 Mar 07
Locked

I'm convinced I am on the wrong planet!

Never mind all the serious high-tech stuff. I have searched Microsoft's Help and pcAdvisor forums for an answer to this simple question, to no avail.

In Microsoft Excel spreadsheets, how do you align the decimal points and also the digits of numbers in a column of cells?

I case I am the only person in the world who has noticed: - In Excel, whatever font is selected, (Including “Courier”) text on the display is always shown in the font “Small Fonts”. Numbers entered in cells are therefore shown in "proportional spacing". i.e. an "8" is wider than a "1". Therefore a number with a lot of "1's" does not align vertically with a number with a lot of "8's" (Try entering 1,111.11 in one cell, and 8,888.88 in the cell below.)

It seems to me to be a simple whim to want the numbers in Excel to align vertically. After all, they do in Microsoft Word!!!!!

1,111.11
8,888.88

What with this and senile dementia. Anyone out there who can help me to sue Microsoft for stress-induced-by-Microsoft suicidal tendencies?

  VoG II 13:29 06 Mar 07

They align perfectly for me using Arial font and the cells formatted as General.

  Batch 13:41 06 Mar 07

I've tried several sorts of formatting (e.g. General, Number, Custom) with both left (using the same number of digits)and right justify and the only time it doesn't line up the decimal point is with debit values (when shown in paratheses).

As far as I can tell, regardless of font, all digits occupy the same amount of space.

  villageidiot 16:54 06 Mar 07

Thanks for the responses.

Prompted into further action by the fact that your numbers lined up, I carried on investigating, and have found the cause.

If the magnification/reduction of the worksheet is changed to less than 80%, then all text automatically changes to “Small Fonts”(?), and numbers no longer line up. Try setting the sheet at 100% magnification and typing a column in say Monotype Corsiva with the heading in letters and a couple of cells as 1111.11 and 8888.88. Then change to 75%.

Why don’t Microsoft explain? Then I would not have wasted another half day of my life.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

Here's what should be coming to Adobe Project Felix in 2017

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…