Ethernet cable to USB port problem

  gel 18:58 13 May 08
Locked

Hi
I am trying to connect an Ethernet cable to a Usb port so that I can connect to a wireless router.
My PC does not have a Ethernet socket so I have purchased a D-Link USB 2.0 fast ethernet adaptor.
The problem is that when I try to install the D Link I get a message 'Windows cannot load device driver for this hard ware- The driver may be corrupted or missing (code 39)'
Any suggestions for a solution please ?
Thank you
gel

  MAT ALAN 19:10 13 May 08

Code 39
Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)
Recommended resolution

Reasons for this error include a driver that is not present; a binary file that is corrupted; a file I/O problem, or a driver that references an entry point in another binary file that could not be loaded.

Uninstall the driver, and then click Scan for hardware changes to reinstall or upgrade the driver.

  brundle 19:12 13 May 08

Version of Windows? Are you installing software and plugging in next, or vice versa?

  Ditch999 19:12 13 May 08

it is a plug and play USB device so Windows loads its own drivers. What OS are you using? Did you try plugging it in to another USB port? Are you logged on as an Administrator?

  Ashrich 19:48 13 May 08

I can't think of too many motherboards that have USB 2.0 but no Ethernet port on them .....even on laptops !

Ashley

  Ashrich 19:51 13 May 08

Thinking about it , why not just plug in a USB wireless adapter if you are trying to connect to a wireless router ?

Ashley

  gel 07:10 14 May 08

Thank you all for your responses.
To reply to some of the queries
I am using XP windows home edition.
My Desk pc is a Mesh with 3 USB 1.0 ports 2003 model but no Ethernet ports ( my dell lap top has 1 Ethernet port and I am connected to this and have successfully installed the Wireless router.
I have tried just plugging in the USB adapter and connected to the router but the installation on the router fails.
I have tried all 3 USB ports.
I am the administrator.
I will try uninstall and re install and search to upgrade the driver
Also I will try brundle suggestion.
Thank you
gel

  gel 15:42 14 May 08

Hi
I have now tried all the above and have been in touch with D-Link.
They say

Go to the link provided below and download the drivers for the device .

click here and download the drivers for the adapter to get it working.

With Regards,
D-Link Technical support

But since I cannot go on line with this PC how do I download the drivers ?
Help please
gel

  Ashrich 18:36 14 May 08

Any way you can downlaod them to the Dell laptop then transfer them ( CD , USB storage stick etc ) then load them on to the PC . As brundle says , load the drivers first , then plug the adapter in to the USB port , it will tell you that it can run faster in a USB 2.0 port , but it should still run Ok .


Ashley

  gel 15:19 15 May 08

Thank you for all your helpful comments.
The problem is now resolved.
Cheers
gel

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…