Error Message: "Run a DLL as an App"

  Colspeed 16:44 14 Jan 09
Locked

I've just replaced an old Lexmark Printer with a Canon MP540. It all works OK but every time I send a document to print an error message pops up that reads:

“An exception occurred while trying to run “C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\cnmsm9E.dll, StatusMonitorEntryPoint USB001; Canon MP540 series Printer;C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\CNMCP9E.DLL;3”

After twice uninstalling and reloading the software, with no success I'm no further forward.

Can anyone please tell me how I can correct this fault?

  Sea Urchin 17:07 14 Jan 09

You say "it all works OK but....."

Are you saying that despite the pop-up message it goes on to print correctly?

  Colspeed 17:34 14 Jan 09

Hi Sea Urchin,

Thanks for response. Yes, strangely, the printer seems to work properly. I'm getting good quality photos and the colour documents are fine too.

But every time I send something to print the error message pops up - I ignore it and the machine carries on regardless. It's just annoying and there's clearly something not right somewhere. Any ideas??

  Technotiger 17:40 14 Jan 09

Try running click here in its default settings, you possibly have a glitch in the registry.

  Sea Urchin 17:52 14 Jan 09

Are you using Vista or XP? Canon printers very often have problems with their drivers for Vista.

  Colspeed 19:20 14 Jan 09

I'm using XP. Manual seems to refer only to Vista but assumed XP would find software OK.

  Sea Urchin 22:17 14 Jan 09

You need to make sure that the disk you have does include the XP driver for the printer. Canon usually includes Vista/XP/2000 as a group.

  Sea Urchin 22:26 14 Jan 09

One other thing - this file (cnmsm9E.dll) from your error report could be suspect - suggest you download and run Malwarebytes to check for any infection.

click here

  jim0203 11:45 22 Jun 09

I'm having the same problem - I've tried Malwarebytes, Spybot S and D, Regseeker, CCleaner, but I'm still getting the problem. Drivers fully up to date. Any idea what I should try next?

  User-1229748 12:18 22 Jun 09

i'm ruuning xp and i was getting run a dll as an app error after upgrading from internet explorer 6 to ie7 or ie8 .mine was an error for a logitech mouse though.only solution i found after trying countless things was to reinstall xp and keep ie6.

  T0SH 13:26 22 Jun 09

The dll file mentioned above is used by the canon printer`s status monitor

I would have thought that canon support would have the answer you are looking for if anyone does

Cheers HC

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…