Epson stylus Photo 1290 Red light Error Help!

  sleen 04:24 13 Sep 15
Locked

My Epson 1290 has stopped working! After startup the middle front button just lights red. It happens exactly in this vid:

click here have tried buying new color cartridges and resetting it, but it still doesn't work. I have looking all many placed on the web but have found no solutions so far. There seem to be more people with this problem. I am willing to repair it manually if its a problem with the printer itself, but i need directions. Can you help me? Thanks!

Here's another post with the same problem but with no solution: click here

I

  mole1944 05:29 13 Sep 15

Have you been to the Epson web site and downloaded the latest drivers,sometimes you have to bite the bullet and get another printer.

  sleen 07:04 13 Sep 15

Yeah i have just installed the drivers. I think its the newest. Still dont work.

  sleen 07:07 13 Sep 15

I have just found this forum where a guy called Eric seems to have solved it. He posts a link that is supposed to be the solution but the link is broken.. I have tried writing him. I will see if he replies.

  sleen 07:09 13 Sep 15

I could still need some help if anyone knows what the problem is. thanks

This thread is now locked and can not be replied to.

Qualcomm Snapdragon 835 benchmarks: Antutu, Geekbench 4, GFXBench and PCMark results

1995-2015: How technology has changed the world in 20 years

This animated short film tells a moving story of domestic violence for Refuge

New iPad 2017 preview: Apple's affordable but underspecced new iPad may appeal to the education…