Epson RX600 ink change

  Roy* 22:01 14 May 05
Locked

Just tried changing 2 ink cartridges ('think' Epson compatible R300-RX600 from choicestationary) and it won't recognise 1 of them (yellow), it just keeps coming up with 'open the scanner unit. Replace the ink cartridge' and I've tried installing a few times now. Is it a problem with this one cartridge as the black seems to show OK and full on the graphic. Any tips please?

  roy 23:02 14 May 05

Hi Roy,

I use 'think' Epson compatibles with my rather old Stylus Photo 700. The only trouble I had with my colour cartridge is that the printer would not pierce the membrane at the bottom of each colour. I didn't like to force it in and solved it by piercing it with a biro first.

This probably doesn't help you but will at least keep your thread near the top.
Roy

  woodchip 23:07 14 May 05

give them a ring i would think a faulty cart as they are chiped

  Roy* 09:31 15 May 05

I've sent Choice an email as they're office ours are 9 til 5 or something and only open Saturday morning at the weekend.

  Roy* 11:24 16 May 05

Bought a Staples one Sunday morning for £7 and that worked fine. Twice the price of Choice but needed it to work.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…