Epson R1900 Printer fails to print.

  Eddiec 16:02 25 Nov 09
Locked

I have recently bought an Epson R1900 printer. It fails to print a full picture on most occasions and fails even with printed,(Letters etc.)pages. The printer works perfectly on my wife's computer (older and less powerful than my own)(five years old) which points to a computer problem rather than a printer failure. The computer is a Asus/Mesh with plenty of memory and a large hard drive. I had a similar problem with my old printer a couple of years ago on this same machine
but that was solved by the use of a Firewire connection rather than a USB. There is no Firewire connection with this later Printer!

Eddiec

  woodchip 16:14 25 Nov 09

Have you tried Downloading the latest Driver for your Operating System and Printer, Remove the Old first before installing the New> Also it's very important you load the Printer and software as Epson tell you to. however this is how I do it with a USB Printer or other USB items, Do not just plug the USB into PC unless the Install Manual tels you to. First load the Software for Printer with USB for printer in other hand ready to plug it in when epson software starts looking for the printer

  woodchip 16:16 25 Nov 09

Your Problem is Driver related

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…