Epson printer USB problem

  astonv 23:10 10 Jul 03

I'm running Win98SE with 2 x USB ports, 1 feeding 4 x hub. I have no problems using scanner, adsl modem and mouse on USB. The epson C42+ is another story. I have upgraded USB Intel chip driver, run set up for the printer god knows how many times and still it appears not to be recognised. Status monitor 3 window shows communication error. Device manager shows no probs with anything, except printer drivers do not seem to be there. Any ideas, Epson seemed to think it is the PCi to USB card, but printer used to work until ink needed changing, now its up the bucket. Thanks.

  woodchip 23:30 10 Jul 03

When you switched on the printer first time what did you do when the Add new hardware wizard popped up. Did you click cancel to the wizard, or did you put the Win98 CD in when it asked you to if you did that?s the problem. You will need to remove Printer in Add Remove programs, and remove all USB in Device Manager after you have removed your printer, then restart computer without the printer, allow windows to reconfigure USB then when it as stoped plug you printer into comp at this stage winWizard will pop up cancel it until it goes away then run your Epson Printer CD with the printer still switched on.

  astonv 23:42 10 Jul 03

OK will give that a go, but think I probably have done before.

  astonv 00:10 11 Jul 03

Hi Woodchip - Have done as you said but sadly the same outcome. Printer has communication error according to status monitor window.

  BillEmm 00:31 11 Jul 03

If you only have 2x USB 1.1 ports on your PC then you are likely to have only one USB 1.1 on-board controller.

This will only provide a maximum bandwidth of 12 Mbps which may not be enough to satisfy the devices you have attached.

The modem and the scanner will take up most or just about all this bandwidth leaving nothing for the printer.

The modem is flexible though, so remove it an install the printer. If the printer works then leave it and the scanner connected and re-install the modem.

ADSL modems will grab as much bandwidth as is available thus leaving little or nothing for other devices so it is necessary that the process I have described is adopted.

If that fails then you will need to install a PCI USB adapter card and I would recommend it be of the USB 2.0 variety.

  astonv 09:42 11 Jul 03

Thanks BillEmm. Have USB 1.1 so will try your solution today and let you know.

  Jester2K II 09:52 11 Jul 03

2 things

1) Is the printer plugged into the hub? Some Lexmark and Espon won't work properly through hubs! Try it plugged directly in to the PC.

2) Is the hub powered via the USB Bus or does it have an external power supply?? If it has its own power supply but its not being used try plugging it in.

I have resolved at least two printer problems in the past using on or the other of these.

  astonv 10:13 11 Jul 03

Thanks Jester2K II. Another option to try.

This thread is now locked and can not be replied to.

Microsoft Surface PC release date, price and specs: All-in-one Surface PC to directly rival iMac

1995-2015: How technology has changed the world in 20 years

Best Photoshop video tutorials: 8 video tutorial websites for Photoshop

Apple's event invitations decoded: A look back at 16 of Apple's most cryptic invites | Clues in…