epson 750 printer "banding"

  katesdad 08:51 03 May 03

my printer has just started "banding" whilst printing, both in colour and black. The machine is abut 3 1/2 years old. Have done head cleaning etc and it appears to be OK. I only use Epson cartridges and my papers vary from Jessops Glossy to Canon PP101. Am running Win ME, although the drivers are for W98 as Epson do not appear to do ME drivers. The quality of the printer used to be very good.
Apart from buying a new printer, can anyone help me get rid of this problem.

  pj123 09:57 03 May 03

I had a similar problem with an Epson printer (not 750) and I found I had to do about 6 or 7 consecutive cleaning cycles. If that doesn't help you could buy a cleaning cartridge from Choice Stationery at click here or Jetica at click here

  Peter 10:35 03 May 03


As pj123 writes, it probably needs head cleaning, but if that doesn't clear the problem new cartridges may be required.

If the printer hasn't been used for a while the cleaning cartridges mentioned above may solve (no pun intended) the problem.


  katesdad 12:01 03 May 03

Thanks for you replies fellas. The printer is used regularly i.e 6/7/8 prints every 2 or 3 weeks for Club comps, plus other text stuff. I'll order one of each cartridges from Jetica and see how I get on.
Will put a reply on here when I've got some news

  Spencus 12:11 03 May 03

Epson cover your problem in their knowledge base click here

  bruno 12:17 03 May 03

I use an Epson 880 and the only two times I had banding was when the printer had not been used for a few days.It then required 5 or 6 cleans as PJ123 said.I have always used compatible cartridges without problems.I was once advised by Canon that cartridges are very susceptible to higher than average temperatures.

  kennyambler 15:44 03 May 03

I have an Epson 870 and i have only used compatables as i traded in them.I used jettec and they are very good.I did develop a similar problem and i used cleaning paper from click here and that sorted it.

  katesdad 00:12 14 May 03

As promised, Results here of head clean - Unfortunately not a clear answer. I got the Jetica cleaner cartidges. Although they did wash the heads through and clear the build up of previous inks, when I put the colour cartirdges back in, I still get the banding, but not as bad as before. I have run the printer several times to allow the inks time to run through, but not a 100% success rate. Now thinking I'll treat myuself to a new printer, so back to the drawing board. Will certainly look at Epson again or one of the Canons(850 or 950). Thanks for your comments

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…