Entering url in Firefox browser, something has changed

  grumpy-git 19:17 PM 27 Jan 12

Up until a couple of days ago I just used to enter a single letter & it would show a list of home pages of sites I had visited beginning with that letter - but now it just shows urls that just contain that letter.

B would give me a dropdown box with BBC.co.uk at the top. C would give me Chiltern Railways home page at the top.

Now B shows pcadvisor at the top because in the url I looked at recently there was a b. Now C also shows pcadvisor at the top because there is a c in pcadvisor

F always showed some forums I visited (forum.name1 forum.name2 etc) but now at the top it shows pcadvisor.co.uk/forum, as it has an f in it.

All this happened when the bookmark icons disappeared. My laptop still works perfectly and is also running 9.0.1.

Any idea what has happened?

  rdave13 19:25 PM 27 Jan 12

Do you have clear history when firefox closes option ticked in options, general tab?

  robin_x 19:25 PM 27 Jan 12

Address bar seemed to get messed up for me with the Google Toolbar extension add-on a while ago.

I disabled it.

  grumpy-git 20:10 PM 27 Jan 12


Just checked the computers and they are both set to "remember history".

  grumpy-git 23:38 PM 27 Jan 12

Have been searching on this and getting nowhere.

Just checked location bar setting & it is same on both computers & is set for suggest "History & Bookmarks". Works as expected on one computer but not the other. Even without closing the browser it seems to forget the home page of sites I regularly visit.

Looked at bbc home page, then typed "b" in location bar & the top url that appears is pcadvisor. The other pc comes up with urls that begin www.b etc.

Still confused.

  rdave13 00:25 AM 28 Jan 12


No better browser than Internet Explorer

you could try Google's Chrome?

  D@ve 02:11 AM 28 Jan 12

My guess is that it's one of the changes made in the newer version of Firefox. Have you checked to see whether they are both running the same versions?

  grumpy-git 10:14 AM 28 Jan 12


Checking the version was one of the first things I did, both run 9.0.1.


I'll stick with Firefox for the moment, unless I get really annoyed with it & can't fix it!!

  Woolwell 11:51 AM 28 Jan 12

Check this - Tools - Options - Privacy tab - at the bottom - Location Bar - Check that History and Bookmarks is selected from the dropdown box or just History if you do not have any bookmarks.

  grumpy-git 14:17 PM 28 Jan 12


I had mentioned a few posts above that those settings were the same on both computers.

I have a very old HP laptop which only normally is switched on about once a week. That runs XP so I will see how that is working and report back later.

  grumpy-git 21:44 PM 31 Jan 12

Just updated to Firefox and things seem more normal now.

I did try the old xp laptop but that was difficult to compare as it has few bookmarks and only limited sites in the cache.

Perhaps the problem has now resolved itself??


This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: Best UK Black Friday weekend deals & best UK Cyber Monday…

1995-2015: How technology has changed the world in 20 years

The best Black Friday Deals for designers and artists – updated

20 Mac Power User Tricks... That You Didn't Know