ECS K7S5A Problems

  hullguy28 11:32 24 May 08
Locked

Hi i have an ecs k7s5a motherboard version 1.0 and managed to corrupt the bios when using flash i managed to purchase a replacement bios but when i switch on the pc it boots up but there is no display i have tried several spare graphic acrds and still the same fault. I was advised i could run a duron 1800 on this board as long as the bios was upto date now the person i got the bios off said they were all updated and new. Has anyone got any idea what could be going wrong as before i corrupted the original bios it worked fine with an athlon 1.0 ghz cpu but would not work with the duron 1800 if i installed the duron the cpu fan kept stopping and starting but had no other life.

When i now switch the pc on with the duron there is no beeps and the cpu fan spins at the correct speed but thats as far as i get any advice would be much appreciated.

Thanks

  Fruit Bat /\0/\ 13:34 24 May 08

V1 only supports up to 1.4

click here

  ACOLYTE 17:42 24 May 08

If i remember right from when i had this Mobo,i was using a Duron 1200 cpu,and needed to flash the bios to use XP cpus,i think i flashed to V1.0A
it was a long time ago now but after that it did work and i installed an XP1800 cpu with no problems.As i said it was some years ago now the board was still pretty new back then.

  chub_tor 17:50 24 May 08

click here for the K7S5A forum, which still appears to be active and might just get you the answer that you need.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…