echoing sound

  kingzogg 16:24 20 May 05
Locked

the sound from my speakers echoes,help please,ta

  Diodorus Siculus 16:26 20 May 05

Have you tried uninstalling / reinstalling the drivers?


Do you know the type of sound card you have?

Waht operating system are you using?

  Jak_1 16:29 20 May 05

Try checking the sound effects! If it's set at 'Concert Hall' then it will echo.

  Joe R 16:40 20 May 05

kingzogg,

As Jak_1 states, there will probably be a sound effects processor, or graphic equaliser, in your sound settings, set to the wrong effect.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

New MacBook Pro 2017 release date, UK price and tech specs: Kaby Lake MacBook Pro to launch in…