Dvd/cd drive in 'computer', keeps vanishing

  trv4n 12:02 21 Jul 09
Locked

Please help.Recently my Pc keeps losing the D: dvd/cd drive in 'computer'. Therefore I cannot save or use any discs.
I have looked in Device manager and uninstalled 'Disk drives' and restarted + it has updated drivers. Occasionally this has found it for a short while. When you try and use it it then stops.

Sometimes( first time in many uninstalls) in Device Manager you see a title: Dvd/cdrom drives & then an exclamation. TSSTcorp cddvd sh-223f ata device
On clicking further on 'Device Status' it says-"Device cannot work (code 10 )-check with Micros oft" =Result 'could not load driver software'.

I uninstalled this + restarted hoping that it would be found and it was not. Now lost.
can anyone help?
thank you

  ened 18:23 21 Jul 09

If you are okay to go inside the machine check the connections.

If that is okay try Google - I typed in your [TSSTcorp cddvd sh-223f ata device] and there were quite a few articles.

  Strawballs 22:18 22 Jul 09

Go to control panel admin tools disc management then I think something like extra's(am at work on tea break and can't access admin tools) then rescan disks it then should show up.

  trv4n 23:08 22 Jul 09

Thank you for your help, unfortunately i am still not sure what to do. When i switch on there is still no disc drive icon and it is not in the string/list in device manager any more...

  ened 06:01 23 Jul 09

Have you checked the connections?

  lotvic 12:38 23 Jul 09

I suggest that you check in BIOS that it is being recognised.

Also how long is it since you changed the mobo battery? it could be running low.

  trv4n 20:33 23 Jul 09

hello, thank you for your replies. The connections when i checked them seemed ok, they were not loose in the socket,i gently pushed on them to make sure they were snug.
How do you check in bios? What is the mobo battery? The computer is 8 months old...

thank you

  lotvic 20:48 23 Jul 09

What make and model is your computer and is it still under warranty?

  trv4n 21:15 23 Jul 09

It's an arbico pc, quad, 2gb. , Yes still should be in warranty. spotted on warm up on black screen
Ultra dna mode SMART capable but disabled?

  lotvic 00:17 24 Jul 09

I suggest you contact shop where you bought it and let them know of the problem DVD it may be faulty in some way.

  ened 07:08 24 Jul 09

My next suggestion was going to be to try another DVD/CD in there but lotvic is right: as it is only 8 months old take it back to the shop and let them sort it.

If you do happen to have a spare lying around, which you know works, it is a two minute job swapping it as a test.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

New Corel ParticleShop plugin now available: 11 new brushes & 6 new brush packs

Apple AirPods review: Apple's beautiful new Bluetooth headphones bring true intelligence to…