DVD Rewriter

  maz2 19:26 09 Oct 04
Locked

I have noticed that my writer has slowed considerably and whn I checked the DMA is switched off, would this be causing it, and if so how do I switch it on? I'm sure it was on before, I've looked in device manager and can't fine anywhere to switch it on, I've looked and use DMA if available is checked but it's using PIO mode, I don't really know what I'm talking about, so if someone could explain to me really simply I'd be very grateful. Running XP home, have DVD played, Writer and CD re-writer installed

  Diodorus Siculus 19:30 09 Oct 04

click here for some details.

  maz2 19:40 09 Oct 04

I've done that and it's still only coming up PIO mode all the others have DMA enabled 1 on the primary and 2 on the secondary, maybe I have too many things installed

  maz2 22:17 09 Oct 04

I don't know what's going on I've updated the firmware (although it didn't really need doing) and it's enabled the DMA, so I'll just have to see how it goes thanks for your help

  maz2 00:38 11 Oct 04

The DMA has turned itself off again now and I'm back to PIO mode any suggestions anyone, it's the slave to the hard drive. I have a cd writer and DVD rom on the secondary and they are both DMA enabled, if anyone has any suggestions please let me know

  curlylad 00:48 11 Oct 04

Turn on DMA

1)Open Device manager.

2)Double click IDE ATA/ATAPI Controllers.

3)Right click Primary IDE channel , and then click 'properties'.

4)On 'advanced' settings' tab under 'Device 0' in 'Transfer Mode' click 'DMA if available'.

5)Under 'Device 1' in 'Transfer Mode' click 'DMA if available'.

6) Click OK.

7)Repeat steps 2) through 6) , replacing Primary IDE channel with secondary IDE channel in step 3).

OK ?

  maz2 11:48 11 Oct 04

I've done that and clicked DMA if available and it's still just giving me PIO it did switch to DMA when I updated the firmware but has now switched back to PIO

  curlylad 13:08 11 Oct 04

Have a look here click here There seems to be a lot of info and suggestions here on a similar problem.

  PA28 14:40 11 Oct 04

Simplistic suggestion. Put your DVD writer on IDE2 in place of your CD Writer and see if you can enable DMA there. This may also speed up your hard drive response times.

  maz2 14:56 11 Oct 04

Thanks for that anyway I'll just have to leave it as it is, as there is no way I'm going to fiddle with any connections, I'm just not up to it, knowing my luck nothing would work after. It just seemed peculiar that the DMA was enabled the other day and now it's not, there must be a reason I suppose, but then again it could be a mystery!!!!!!!!!!!!

  PA28 15:09 11 Oct 04

You could also check your BIOS detection settings........

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

iPhone 9 and beyond: 32 amazing future smartphone developments - graphene, supercapacitor…