Drivers missing

  timestar 10:19 27 May 08
Locked

Laptop crashed over week-end and had to reformat HDD and re-install XP Pro SP2. After doing this, in Device Manager have yellow exclamation marks next to the following: Base System Device (3 of them), Modem Device, SM Bus Controller, Video Controller (VGA Compatible).
I have a CD from Dell that says contains drivers but when I attempt to update drivers for these says it cannot find them on the CD.
Laptop is a Dell Inspiron 1520.
Any help please?

  wotbus@ 10:29 27 May 08

Have you tried to let Windows update the drivers from it's generic source?

  timestar 10:31 27 May 08

It won't update drivers from the Dell CD or from the Internet.

  johnnyrocker 10:35 27 May 08

have you tried unistalling from device manager re boot and see if windows finds them?



johnny

  Eric10 10:35 27 May 08

From the Dell website click here

  ICF 10:36 27 May 08

Have a look at the Dell website:-
click here

For your modem look under Communication
For your SM Bus Controller look under Chipset
For yourVidoe Controller look under Video

  timestar 10:37 27 May 08

Try tried downloading drivers from Dell web site but still have the yellow marks I mentioned above.

  Eric10 10:43 27 May 08

How are you trying to install the downloaded Dell drivers? You need to run the files which will extract from their zipped form and then install. You can't install them from "Update Driver" in Device Manager. I've recently installed drivers for a Dell Inspiron 1300 in this way.

  timestar 10:47 27 May 08

What about the drivers for the 3 Base Devices?

  Eric10 10:50 27 May 08

The base devices are probably covered by the chipset driver.

  timestar 11:19 27 May 08

Installed drivers - all exclamation marks now gone and finally display looks normal again. Cheers all!

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation techniques

How to mine Bitcoin on Mac