Drive Not Accessable?????

  paul 17 09:05 16 Oct 04
Locked

I keep getting the message E:/ (or whatever drive)not accessible, the device is not ready. This is on both my CD drives ive tryed swaping cables other (working) drives all to no avail theyre getting power and will eject from the menu. anyone any ideas?

  JonnyTub 09:16 16 Oct 04

more info please, operating system, order of events leading up to problem, etc.

  paul 17 09:41 16 Oct 04

it's a friends computer bit of a shed but has worked fine until now its on windows 98 and its an early pentium. it just stopped working one day everything else is fine

  JonnyTub 09:51 16 Oct 04

Is there an exact error message?

If it's "just stopped working one day" then the first port of call would be a virus scan, secondly to save a lot of hassle take one out and try it in your machine. If it doesn't work in yours then it's knackered and saves time trying to doagnose a non - existant fault in the os.

Thirdly, once you done this try click here

  paul 17 10:11 16 Oct 04

1. yes drives work fine in my computer
2. Ran a virus checker and she already had quite a good one(mc afee) running
3. Gonna try this one later
would it be semi safe to think if this fails that MoBo is at fault? would trying her hard drive on my MoBo to try and eliminate it being at fault be worth a shot?

  JonnyTub 10:15 16 Oct 04

I doubt it's the mobo, more likely something like drivers have become corrupted (ide or drive), the aspi layer needs reinstalled, or trying a cd lens cleaner. If the drives are on the same ide cable, then try a different cable.

Her hard drive probably won't boot on your mobo.

There are tons of different ways of trying to fix the drive no accessible, it's just a case of trying them all seeing as there are so many different solutions.

  Fruit Bat /\0/\ 11:48 16 Oct 04

Most problems like this are caused by the IDE (ribbon cable) especially at it seems to be both CD drives on same cable, cheap to replace and retry.

  paul 17 14:31 16 Oct 04

tryed the cable and power source was one of the first thing's i did, both fine cant try a lens cleaner as they wont run, just open and close!

  Fruit Bat /\0/\ 14:42 16 Oct 04

Uninstall the IDE/ atapi drivers in device manager and reinstall.

  paul 17 21:00 16 Oct 04

wot a day tryed everything now more or less all at once and touch wood its workin! thanks to everyone who offered advice.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…